5 Replies Latest reply on Jul 23, 2013 12:47 PM by Glenn Schroeder

    Remove dimension lines for outside arrows Selected

    Tony Lavigne

      This check box is located at...

      Document Properties/Dimensions/Linear/Text Position

      By default it is unchecked.

      I believe if the arrows are on the outside of the leader lines it, by checkling this box SW doesn't draw the dimension line between the leader lines.

       

      The problem is it's not working for me.  I'm trying to dimension  without leader and dimension lines crossing.  I  know there is the option to break dimension or leader lines but it's not what I want.

       

      Another option is to convert the text in the dimension from horizontal to vertical but I don''t think Solidworks will let you do it.

       

      Enclosed are some jpg's to help explain what I'm after.

      Thanks

      Tony

        • Re: Remove dimension lines for outside arrows Selected
          Glenn Schroeder

          Tony,

           

          Welcome to the forum.  For your first screenshot, after placing the dimension, click on it to highlight it.  Go to the PropertyManager, the Leaders tab, then click on the top left icon in the "Witness/Leader Display".  That will put the arrows on the outside of the leaders without a line between them.

           

          no lines.png

           

          For your second screenshot, I'm afraid I don't understand what you want.  You say you want the text to be horizontal, but it is already horizontal.

            • Re: Remove dimension lines for outside arrows Selected
              Tony Lavigne

              Glenn,

                I see in your screen shot that there isn't a line and this is what I want.  In my screen shot I also have the arrows on the outside but the middle lines I cannot get rid of.

               

              I messed up on my second question, the text by default is displayed horizontally.  I want to make it vertical.  I seached extensively in forums and SW Help and I cann't find an answer.  It seems like it would be pretty useful and so trivial to do.

               

              Thanks

              Tony

                • Re: Remove dimension lines for outside arrows Selected
                  Glenn Schroeder

                  1.  If you have the button clicked that I have the red box around and you're still getting the line then go to Tools > Options > Document Properties.  Expand Dimensions and choose Linear.  For "Base linear dimension standard" choose ANSI from the drop-down.  I think that will fix it.

                   

                  2.  The only way I can think of is to get dimension text vertical is to use Ordinate Dimensions.

                    • Re: Remove dimension lines for outside arrows Selected
                      Tony Lavigne

                      Glenn,

                        That did it for my 1st question!  Choosing ANSI in Base Linear window took away the center line.  Thanks for replying.

                       

                      I don't think SW allows the toggling of dimensioned text from horizontal to vertical and visa versa.

                       

                      Tony

                        • Re: Remove dimension lines for outside arrows Selected
                          Glenn Schroeder

                          For the second question, you could make it work, but it's a pretty involved work-around.

                           

                          1.  Insert the dimension.

                          2.  Link a note to the dimension and rotate it (90° or 270°).

                          3.  Hide the dimension.

                          4.  Insert another identical dimension, over-ride the value, and hit your spacebar to insert a space for the dimension text.

                          5.  Place the note so it looks right in relation to the dimension leader lines.

                          6.  Group the note and blank dimension with the Align toolbar.

                           

                          Like I said, it's pretty involved, and I'm not recommending it, but it should work if you have one or two that you just have to turn.