1 Reply Latest reply on Jul 22, 2013 3:28 AM by Ian Worrall

    2013 SP0 can't install on Win 7 anymore

    Daniel Brett

      HI,

      I went out on the limb and bought SW 2013. I tried the 2012 for 30days, learned enough to do the job, got my urgent project doen , that 10 other drafters apparently couldn't do, within the 30 days and decided to buy it, as do-it-yourself seems the way to go. Anyway, I loaded the 2013 which came as SP0 and went to SP1 during install. I pretty much have not used the software since the end of January, because my first project was under way at the mold making shop, and that took awhile. This month, July, I tried to use it for project 2. Every command took approximately 2 minutes to execute. I was told to try repair, uninstall, or reinstall. All failed, and now I have nothing. There really seemed to me, there is some conflict within the pc between SP0 ad SP1- which apparently no longer exists. I finally killed off all files associated with SW, including registry - because I could not even uninstall it successfully, so I manually removed it all, or at least I hope I got it all. I did that again with tech support too. 

      With a fresh machine, I now have support here, and it's still not working to install, and we are now in week 3, and my project is behind.

       

      What currently happens is when running the installation for the CD, I get the failure window that says :

       

      "Internal error: The Windows Installer for this product component did not run as expected: SWRegistration"

       

      We've played with .net framework and a few other things, and we're at a point of saying I need to reformat my pc. This is a brand new pc, bought in Dec '12 for this software only, at the time I got the software. big investment for me. I really don't use this pc for anything, because I wanted it for SW only. No surfing, no email, etc. The only thing that happens is it gets put online each Friday night, and Microsoft and virus updates are done. So, it seems odd that I might have to reformat it, which also makes me nervous as they never get back to the original factory specs, at least from what I've experienced in the past. I would guess something went off between SW and MS, from the basic evidence.

       

      Anyway, I am wondering, if the issue is with  "SWRegistration", can there be a problem on the SolidWorks server's end of things, where my serial number confirmation is located?

      Again, my clue is the serial registrations will say I'm valid to SP1 during the start of install, but, on the list of upgrades, there is no SP1 anymore.

       

      Support even tried loading a new CD with SP3 using his serial number, and it fails same way.

       

      That makes me really think- Could the registration, that  I'm registered under, be asking for, or being asked for, something that does not exist anymore, or is there a lingering file on my pc that is hidden somewhere?

       

      I'm told that my individual computer has also been ID'd by SW servers. Is that true? And is it linked to my registration somehow? could it be corrupted?

       

      Is it possible to erase my info from servers, and re-issue my serial number, as if I just bought the program again?

       

      I've worked with software folks in the past, and I try to get to the root of error codes; if the creators are still around: My question would be-

       

      who wrote the failure mesage, and what exactly triggers that message to come up?  Answer that exactly, and we'll probably know what to do.

       

      Somebody out there wrote this software, and should know exactly what  the message is triggered by, and what we're looking for, instead of all this trial and error troubleshooting. Where is that person?

      That would be my first steps to resolving this issue if I were on the inside.

       

      FYI- I have also tried with all virus software and firewalls turned off.

       

      It really hurts to be down like this when  your the little guy.

       

      Any input on this would be greatly appreciated!!!