7 Replies Latest reply on Mar 8, 2019 5:22 AM by Eero Luotio

    Workflow Export Error

    TOLGA Dirmikci

      Hi everybody,

       

      What is this error ? How can i fix this error ? "an invalid argument was given to the method"

       

      Workflow export error.JPG

        • Re: Workflow Export Error
          Jim Sculley

          There are several different problems that can cause this error.

           

          Try exporting each category (Workflows, Users, Groups, etc) separately until you find the one that is causing the problem.

           

          Also, see SPRs 668232 and 478119.

           

          Jim S.

          • Re: Workflow Export Error
            Sam Sam

            Hi,

             

            Also will not prevent to check Actions in transition time (especially settings of Variables), the sequence of these Actions and also Conditions of transitions.

             

            But the reason can be as well in the Workflow settings (for example - life extensions), conditions, categories, etc.

             

            It is also possible to check execution of transition under the user Admin - to be convinced that there are no problems in the rights of the user.

             

            And of course to try - to ignore permissions in the previous statuses - perhaps a problem in it.

             

            Still, check Patch for Export - if it wrong or just does not exist - Export cannot create this folder.

             

            Practically, probably it is better to copy problem Workflow in test Vault and deleting one part of settings for another - to look for in what there was a problem.

            • Re: Workflow Export Error
              Dan Harlan

              For reference, S-073862 provides a SQL script to detect the most common cause of this issue (deleted users linked to workflow notifications).

              • Re: Workflow Export Error
                Eero Luotio

                Basically you will have to start SQL Trace for your database(filter by ConioAdmin.exe), one of those SPRs should have instructions.

                 

                When you do that export you will see the latest procedure happening and there is normally the reason.

                Example if user have created workflow and deleted after that. That user fails, you will have to enable that user.

                 

                I also had problems that someone had deleted variables from solidworks pdm, I had go one by one variables trough from trace and readd them, after that it started working.

                Go trough all of those SPRs