3 Replies Latest reply on Jun 5, 2013 8:45 PM by Bogdan Arefta

    Sweeps remove eachother?

    Sybren Zwetsloot

      Hello everyone,

       

      I recently started playing around with solidworks because I was bored. So, i've been making a model for a race car as a first project. However now when I make two sweeps in one part, the first sweep is removed when the second is created. If I suppress the second sweep the first one shows again.

       

      As a side question, does anyone know how to copy an edge of a surface onto a sketch plane?

       

      I attached my project for reference, the problem occurs between sweep11 and sweep14 in the front bumper part.

        • Re: Sweeps remove eachother?
          Tom dunn

          I deleted your sweep2 and the sketchs involved. I then created a new sketch on your end face of the existing bumper. I used the convert entities command which takes the face and changes all the outside edges to a sketch. I then extruded the new skech9 to a distance of 86.61 which is the same as the length of your old sweep length.

           

          I believe your second sweep was using derived sketchs from goemetry that you use earlier and deleted. I think this is why your first sweep was disappearing on you.

          • Re: Sweeps remove eachother?
            Jesse Robbers

            The two sweep features work OK when merge result isn't selected resulting in 2 bodies. The sweep would not build for me or using the combine feature to merge the two bodies together. Your 2nd sweep profile sketch is the reason why. This sketch needs to be more simple and more similar to the profile of the face the sketch is drawn on or you end up with the 'cannot build due to geometry problems or zero thickness" type errors. I deleted the spline(s) you had in this profile sketch, retained the vertical lines for the width, converted entities of the face and trimmed the slop away.

             

            The surface edge onto plane would be convert entity sketch tool whilst in a sketch on the plane you want the edge placed upon.

            • Re: Sweeps remove eachother?
              Bogdan Arefta

              I came across this problem too 6 months ago when I was trying to model up a piping wye piece with sweeps or lofts I can't remember. I think it's a bug that picks up a negative sign from one of the sketches (reversed plane or something like that) and applies it to the body combine operations. This is why it works when you tick off the merge bodies option. You will also find that add, subtract and common options from your combine op. are no longer working by the original intended logic. I think in the end at SWX support team's suggestion I got my one body wye piece by using combine - common! which was wrong but nevertheless it worked. Should I mention the bug carried on in the assembly when I tried to "fill" the piping with water? ... can't tell the frustration. I so wish the development team will one day get their ducks in a row because it became a tradition to have them all over the place.