AnsweredAssumed Answered

Unable to Write Custom Properties during Check In

Question asked by Pat Goettig on May 10, 2013
Latest reply on Jul 21, 2014 by Andrew Van Denend

Hello,

 

I am having trouble with checking things into our workgroup PDM vault.  Here is a summary of what is happening:

 

I finish creating a drawing or an assembly and I attempt to check it in to the vault.  I edit the custom properties that I want to (ie. description, drafted by, approved by, date approved, etc.) for both the drawing and the associated sldprt file.  I click check in and then it gives me the following error:

   Solidworks Error.PNG

I don't ever run more than one instance of Solidworks and I have had this issue both when the associated part was open and when it was not open.

 

I tried deleting Solidworks completely and re-installing and then restoring my settings files (without and with system options).

 

I even completely re-installed Solidworks and didn't restore my settings files.

 

Every time I tried one of the above solutions, Check-in functionality would go back to normal for a couple days but then start giving me this error again.

 

I contacted our company's reseller and they gave me a work around that I am not happy with.  Basically, they said after I check stuff out of the vault I need to move it to a different folder before checking it back into the vault and then it will work.  This does work, but I don't understand why I have to do this in the first place because I shouldn't have to.

 

Also, this does not happen when I check-in the part first, only a drawing or assembly.

 

I even tried disabling the "Search file locations for external refrerences" box in the System Options->External References section.

 

Has anyone ever come across this before or know what is going on?

Outcomes