6 Replies Latest reply on Jan 21, 2014 1:40 PM by Karen Brunke

    Why do some files not get "added to the vault" and others do?

    Karen Brunke

      Why do some files not get "added to the vault" and others do?  I am automatically creating pdf files thru a workflow transition.  They don't get added to the vault.  If I RMB, add to vault, then they go thru the automatic workflow created for them to check them in.  If I copy then paste them over the top of themselves, they get added, then go thru the workflow.  I see similar behavior for SWX files if I PNG an assy into a vault folder.  When the files are first created, they local files, after a short lag, they add themselves.  With the PDFs, they never add themselves.

        • Re: Why do some files not get "added to the vault" and others do?
          Joy Garon

          Hi Karen -

           

          Look in the knowledge base solution S-049622

           

          --

          First verify that the logged in user (or user defined in task) has permission to add files to the output folder, if not the file will be created locally but not added to the vault.

           

          On some systems, it may be necessary to include the PDF extension in the logged in user's "adding files" list in user settings (right-click user, settings, adding files). Add PDF to that list. (see attached screenshot)

           

          If triggering the PDF output via custom API code (dispatch running an .exe for example) it is recommended to create the output file in a local folder and then copy that file into the vault as that ensures the file is added correctly. Alternatively use the API method IEdmFolder5::AddFile.

           

          ---

          Joy

            • Re: Why do some files not get "added to the vault" and others do?
              Karen Brunke

              Another solution was added to the Knowledge base that FINALLY helped me get resolution to my problem.  It is S-060625, and it says that files with a double \\ in the filename will be created, but will not ADD to the vault automatically, remaining local.  I debugged my code AGAIN looking specifically for this issue, and I found the error.  It now works perfectly placing pdfs created from files in one folder into a parallel folder.  Here is the code I added in the location shown in S-052490

               

               

              Dim ConvertedOutputPath As String

              Dim FileWRevOutputPath As String

              Dim FileWRevIntOutputPath As Integer

              FileWRevIntOutputPath= Len(convFileName) +1 - InstrRev(convFileName, "\")

              'Get Project path

              ConvertedOutputPath=Left$(convFileName, InstrRev(convFileName, "SWX_Data") -1)

              FileWRevOutputPath =Mid$(convFileName, InstrRev(convFileName, "\") ,FileWRevIntOutputPath)

              'New output path

              convFileName = ConvertedOutputPath & "PDFs" & FileWRevOutputPath

            • Re: Why do some files not get "added to the vault" and others do?
              Karen Brunke

              There was a lingering Dispatch action causing the SWX parts to act funny.  I forgot to remove it.  However, the PDFs are still acting the same.