AnsweredAssumed Answered

"Could not access the item in the database" when trying to destroy deleted items

Question asked by Wayne Lehman on Apr 19, 2013
Latest reply on Apr 23, 2013 by Charley Saint

I have a number of seemingly empty folders in a SolidWorks EPDM 2012 SP3 vault that are tagged as deleted, but when I attempt to destroy them, I get an error stating:

 

"Could not access the item in the database"

 

I have tried restoring an earlier version and checking out/in and hoped that the vault cleaner service would help, but just cannot get rid of the folders. Also tried modifying the user profile to only show files that are part of the vault and checked the local file clean-up to delete local read-only files that are not part of the vault.

 

Entry from the EPDM Administration log file as follows:

 

Description:

Error running query in SpDbOdbc

State=23000

Msg=[Microsoft][ODBC SQL Server Driver][SQL Server]The DELETE statement conflicted with the REFERENCE constraint "FK_ControlledLists_CardControls". The conflict occurred in database "bob2013", table "dbo.ControlledLists", column 'DestCtrlId'.

 

========= LAST COMMAND ========

Del_ApiDestroy 2

 

Server: samwise\epdm

 

Database: bob2013

 

Date: 2013-04-18 16:23:28

Module: Explorer.EXE

Function: hGetErrCode

Error code: E_EDM_DATABASE_ACCESS

 

Error code general description:

Could not access the item in the database.

 

Any help would be greatly appreciated.

Outcomes