AnsweredAssumed Answered

Saving an assembly takes very long

Question asked by A. R on Apr 11, 2013
Latest reply on Apr 15, 2013 by A. R

Hello, everyone,

 

Me and my colleagues are having a problem with particular assemblies in SolidWorks 2011 SP5.0.

The same problem occured once before (not so long ago), but we ignored it as a one-time issue and moved on. Now it happened again and it just stops our work completely, so, I decided to identify and fix it. Thus, I need Your help because I tried what I could and it didn't help.

 

PROBLEM: A particular project started to become awfully long in saving and updating times (I am talking about 5+ mins).

 

OBSERVATIONS:

 

  • I think it's rebuilding and saving every part of the assembly (there are about 180 of them), because when I press SAVE button, it shows the box with SAVE ALL option and all parts and assemblies listed with ticks beside them (see attached picture);
  • We are working on the network and we usually put projects on server, then edit something and CHECK IN through PDM. Normally, if we edit one part, only that one is checked-in to server, but on this particular project, every part and assembly is checked in, even if minor changes are made;
  • What's strangest is that it's just for this (and the other older one that I mentioned) project. Everything is OK with other ones (some of them having even 400-500 parts);
  • Opening the project in LIGHTWEIGHT brings better performance, so we are working using it, but again, when some parts are resolved to normal view, they are starting to be saved whethere they are edited or not;
  • It looks like somehow the assembly itself is "infected";

 

ACTIONS:

 

  • Tried disconnecting my computer from the network - no change;
  • Tried renaming the whole project (parts and assemblies) to avoid any similar names - no luck;
  • Tried reuploading the project to server and checking it out on other computer - still no luck;
  • Tried "Pack and Go" to another computer - the same is on every other computer;
  • Tried bringing the whole project to my personal computer and opening project with SW2012 - still the SAME thing when saving (like in attached picture);
  • Tried removing the last parts that were added before this problem - minor changes, but still way NOT normal;
  • Tried removing parts that are taking longest to rebuild (information from AssemblyVisualization) - again just minor changes;
  • AssemblyXpert doesn't see any problems;

 

If I will remember anything else, I'll edit the post, so I am waiting for your thoughts and suggestions on this one.

 

Regards to everyone,

A.R.

Attachments

Outcomes