6 Replies Latest reply: Apr 16, 2013 8:49 PM by Artem Taturevych

    What am I missing with this Addin setup?

    Jason Kerns

      I have my completed Addin and I used Installshield to create my install exe, I ran into the "C:\WINDOWS\Microsoft.NET\Framework64\v4.0.30319\RegAsm.exe" problem.

      My add in uses the post build script that the SDK provides, I thought that was supposed to take care of this issue.

      I run the exe on a target computer, Solidworks does not find it, I try to run a bat file for the regasm, and at first it prompts me with, "Run as administrator", so I run it as admin and it flashes then disappears. So I manually go to the Command prompt- run as admin- and type the whole regasm line manually and it works.

      I must be running into permission issues.

      I do not want to have to type the regasm manually for every computer i install.

      Does anyone know why my install exe does not register my addin?

       

       

       

       

      notes:

      SW 2013 x64

      1st Visual Basic Express 2010

      2nd Visual Studio 2010 30 day trial <- I thought this would have solved my issues lol

       

       

       

       

      also a big thanks too Luke Malpass, and Jacob Cordingley!