2 Replies Latest reply on Mar 15, 2013 1:12 PM by Alex Rowland

    Assembly referencing Parts that don't exist, but once did.

    Alex Rowland

      Okay, first post, let's make it a good one.


      I am having problems with an assembly file referencing parts that don't exist. I am using SW2012 SP3 and EPDM. Here is how I got myself into this mess.


      Our vault is setup with basically two main folders, Let's call them Archive and New. We use Archive to house all of our part and assembly files where the drawings exist in some other form (AutoCAD, Inventor, etc.) We use the New folder to house new created drawings, parts and assemblies.


      Now here is what happened. We create many assemblies that are similar to each other, and i was duplicating a drawing and top level assembly with pack and go, so that I could modify it and make my next assembly. I am guessing, although I don't know for sure, that i forgot to uncheck all of the appropriate boxes on the left hand side of the Pack and Go Dialog. What happened is that some of the parts from the Archive folder are duplicated in the New folder. The problem lies in the fact that these parts are now being seen by the server, and I cannot delete them (Don't have permissions to do so). It also says that these parts are checked out to me. I thought nothing of it, and kept working making my new assembly.


      The first problem. When I check in this assembly, and my boss pulls it up. It gives him warnings that the parts don't exist and he needs to find them. That's annoying, but we can deal with it.


      The second problem. When I open the assembly, it always pulls parts from the New folder not the Archive folder. Even if I check it out, change things, delete things. If the file is the same name, its coming from New.


      Complications. So this is were things go wrong, I need to change one of the parts from the Archive folder (add a new configuration for a different hose routing.) I change the file as need and put that file in my assembly. Save, Check In, Close down, Open up. The file changes back to the hose in from my New folder, not the hose from my Archive folder. No matter what it pulls from the New folder.


      Potential Solutions that I have tried.   I tried as many things as I could think of to fix this, but I figured I would list them to potentially expedite the troubleshooting process.


           1. I tried having the admin delete the files from my New folder in order to break the link, and have Solidworks prompt me to find the Archive file.

           2. I tried deleting the file(New) from the assembly and adding the file(Archive) to the assembly.

           3. I tried using the Edit Reference File Location dialog box in the Open Dialog box to change the references.

           4. I tried using the Edit Reference File Location dialog box in the Contains tab in the Open dialog box.

           5. I tried saving a copy of the file to my desktop, and changing the file references while working in offline mode, and then saving that assembly back into the New folder.

           6. I tried opening one part from the assembly and doing a Save As back into the Archive folder to have overwrite and keep the references.


      Nothing seems to work. If I pull up that assembly it pulls the version from the New folder.


      Here is the weird thing, the version from the New folder doesn't exist. It has been delete, and I cannot navigate to it in the Open Dialog box. I can't find it in Windows.


      I am at a loss.


      Thanks in advance,



        • Re: Assembly referencing Parts that don't exist, but once did.
          Craig Lalumiere

          Welcome to the forum!


          We hit this the other day, from the sounds of it you have local files in you vault. in the user settings menu under explorer, turn on the setting show all files. delete the local fiels and re reference them where they need to go.


          This needs to be done on all the machines because they will all will have local files for the original document.


          I also found copy tree works better in EPDM than Pack and go. there mostly the same thing

            • Re: Assembly referencing Parts that don't exist, but once did.
              Alex Rowland

              I got on the phone with our tech support people, and they answered the question for me but I figured I would hop back on here and share the answer, and your response is close.


              In EPDM, when you delete something, it doesn't completely get rid of it. It still exists in the folder, but users cannot see it. So when i had the administrator delete the files, they weren't completely removed. That is why my assembly was still pulling out the files from the New folder. In order to completely get rid of something you have to "Destroy" it. To do this, RMB in the white part of EPDM, and go to properties. In the properties window, there will be a tab for Deleted Items. You have to select the files in that tab, RMB and Destroy. Then Solidworks completely gets rid of them, and should propmt you for missing parts when you open the assembly again.