6 Replies Latest reply on May 15, 2014 9:23 AM by Glenn Schroeder

    Dual Dimension bug?

    Glenn Schroeder

      Hello,

       

      I don't know if this is a bug or if I'm doing something wrong.  I have a drawing set up with Document Properties > Units at IPS, with dual units set to Meters.  That's fine until I Override a dimension and change it from displaying Inches to Feet and Inches.  When I do that the dual dimension changes from meters to millimeters.  If I set the dual dimension to millimeters, then it doesn't change when I override the primary dimension units.  Any ideas?

        • Re: Dual Dimension bug?
          Jessie Underwood

          Glenn,

           

          I will back you up  on this. It may be a glitch in 2013. I am running 2013 x64 Edition, SP0.0. We are getting the same problem. I thought it may be a problem with our template set up, so I opened a sample drawing files that comes with SolidWorks. I got the same results. No matter what I have set as my dual dimension, under units, as soon as i check the "Override Units" the dual dimension changes to mm. See attached screen shots.

          dual dimm problem1 shows my unit settings and a dual dimension without over ride

          dual dimm problem1 shows my unit settings and a dual dimension with the "Override Units" checked.

          dual dimm problem1.JPGdual dimm problem2.JPG

          • Re: Dual Dimension bug?
            Patrick O'Hern

            I've noticed this as well, any time you override the primary dimension type, the secondary always switches to MM.

            • Re: Dual Dimension bug?
              Alin Vargatu

              Vote on this SPR:

               

              SPR 420182: dual unit changes to MM without reason when overriding length unit in drawing's dimensions

              • Re: Dual Dimension bug?
                Mark Deboer

                I found a little work around for this if anyone is still dealing with this bug. I wanted to have both inches and feet and inches displayed and my normal dim style is inches on all other measurents. I would override inches unit to feet and inches and get the mm dim for the dual dim value, thats not what I wanted. So to get feet and inches and also inches, I went into doc properties and to the units page, there in the units for the dual dim I changed it to feet and inches, so now on the drawig when I select it to display a dual dim, the dual dim comes in as feet and inches, no overriding dim is needed. Hope that helps someone.

                • Re: Dual Dimension bug?
                  Glenn Schroeder

                  Still there in SW2014 sp 3.