AnsweredAssumed Answered

Configuration specific design table update problems

Question asked by Martin Miller on Feb 20, 2013
Latest reply on Sep 19, 2019 by Chris Appleby

Hi all,

 

I am having a problem which is sending me round the bend. I apologise because I know this has been asked before however I have read all of the threads regarding weight updating problems and I still cannot get a list of weights for all of my configurations which is updated.

 

I am using SW2011 SP4.0 and have a part which has over 50 configurations all of which I need to get the weights to do some rough costing.

 

I have been through and added Configuration specific properties for material and weight to all the configs which took way too long. However when I try to go back and look at the values or look at them in the design table I auto created I get the star* with the message *Calculated the next time the configuration is active.

 

config_sepcific_tab.PNG

 

I have tried a couple of macros to run through and update all the parts which unfortunalely is of no help at all.

 

The first one I tried was one which forces a rebuild of all the configurations and the second is one which updates all design tables.

 

This is the design table as I have it now after trying several things to get it to work including trying to add $SW-MASS as a column header

DT.PNG

 

Everytime I leave the DT I am getting the balloon saying The following custom properties were not updated.

 

custom_props.PNG

 

The long way round would be to open up each configuration activate the config specific properties and hand write the weight down to later copy up into a spreadsheet however after I have done this part there are several other parts which I need to do the same for and this will take me days

 

I hope this is making sense.

 

I suppose the question would be: Is there another simple way to get a list of all configuration part weights?

Outcomes