1 Reply Latest reply on Feb 15, 2013 11:36 AM by Jared Conway

    Flow simulation won't calculate - "No fluid volume"

    Daniel West

      Hello,

       

      I am trying to run a flow simulation on a car I have made for my school's 'F1 in Schools challenge' team. For various reasons, I designed the car in Autodesk Inventor but I need to use solidworks to run an airflow simulation.

       

      I tried importing the file directly from Inventor, but that resulted in gaps and geometry errors, so I experimented with a range of file types exported from Inventor. The .sat file type seemed to work pretty well as there were no errors upon import and the car seems to be made of solid bodies. I can run the flow simulation wizard perfectly, but when I try to run the actual calculation, I get an error which states:

       

      There is no fluid volume in the project. Please check geometry or boundary conditions.

       

      This doesn't make much sense to me, can anyone help me out?

       

      Here's the file converted to Solidworks format:

       

      http://dl.dropbox.com/u/41931267/Wind%20Test%202.SLDPRT

       

      Thanks!

        • Re: Flow simulation won't calculate - "No fluid volume"
          Jared Conway

          hi daniel, in the flow simulation pull down go to tools > check geometry and run a check geometry test

          you'll see there are many invalid contacts and invalid surface pairs

           

          some sources of problems that i can see:

          1. if you cut your model down the middle, you'll see a lot of sliver cuts. flow simulation is likely having trouble figuring out which volumes to ignore.

          2. if you drop your part into an assembly and run an interference detection (include multibody parts), you'll see many interferences. those will also cause problems.

           

          for your external analysis, I would get your model so that it is 1 solid body. if you're going to have multiple bodies, make sure that they touch face to face and don't generate any gaps between them. (you can check this with interference detection using the "treat coincidence as interference" option)

           

          a technique we would normally use to fix this is to build a big solid cube over your model at the assembly level and then use the cavity function to "fill" the gaps and then merge them to the rest of the bodies. however with the interferences..etc, it might be difficult. try using the combine command at the part level first and see if you can eliminate some of the interferences..etc.