1 Reply Latest reply on Jul 28, 2013 1:12 PM by James Biggs

    Dell Precision M4700 Optimus issues (Nvidia Quadro K2000m)

    Christopher Thompson

      I recently upgraded from a Dell M90 to a Dell M4700 workstation with an Nvidia Quadro K2000m video card, and initially the performance was poor as I was experiencing a 2-3 second delay (Re: Slow responses-SW2012 w/Windows 7). I believe I have located the problem, and it is the Optimus setting for the display adapter.

       

      As I have to use the Nvidia Quadro K2000m since the integrated graphics processor is not adequate, here are the steps I used to try to resolve this problem:

       

      1. Downloaded updated driver (www.solidworks.com/.../videocardtesting.html) which is 306.68 (Win 7 x64), and uninstalled all previous Nvidia drivers.
      2. Disabled the Optimus setting in the BIOS (Screen will resemble safe mode when booting up).
      3. Installed current Nvidia driver, and then the device manager will show only the K2000M video card (previously showed both the Nvidia Quadro k2000M & IGP) under display adapters.
      4. Please note I have not tested this using a docking station with external monitor, so I cannot guarantee the results nor have I tried reactivating the Optimus setting in BIOS.

       

      Intially, I thought the problem was related to a Raid 1 configuration (mirrored hard drives), but I believe the Optimus setting was the main issue. I still have an intial delay when selecting the very first part to open in an assembly, but not for the subsequent parts & features. I am wondering what others have done to optimize settings on their Dell M4700 workstation.

       

      Here is more information from the Solidworks technical support (Solution ID S-056739):

       

      Question:


      What may cause poor performance or unexpected graphics behavior with SolidWorks on new laptops that have NVIDIA® Quadro graphics cards, for example: Dell™ M4600, M6600, Lenovo® W520?

      Answer:


      This is likely caused by NVIDIA's Optimus Technology (see link for more details). If this technology is not configured correctly, SolidWorks will use the laptop's integrated graphics processor instead of the NVIDIA processor, and this will result in poor performance and unexpected graphics behavior.

      This technology is configured in the NVIDIA Control Panel. The default installation of the driver* has a correct configuration for SolidWorks. To default configuration is the following:

      1. Open the NVIDIA Control Panel
      2. Select the "Manage 3D settings" task
      3. For Global Settings**, choose "Auto-select" and click Apply
      4. For Program Settings, make sure "Show only programs found on this computer" is checked. Dassault Systemes SolidWorks will be detected. Ensure that "Use global setting (Auto-select: NVIDIA GPU)"** is selected.

       

      You can also choose to disable the Optimus technology. This requires modifying the laptop's BIOS. Please contact your laptop's manufacturer for assistance with that.

       

      *this applies to SolidWorks certified graphics drivers: www.solidworks.com/.../videocardtesting.html

       

      **additionally you can choose "High-performance NVIDIA processor"

        • Re: Dell Precision M4700 Optimus issues (Nvidia Quadro K2000m)
          James Biggs

          my M6600 with Q4000 will not start solidworks with optimus enable AT ALL. it freezes on the splash screen at "loading registry"  I do know that its activating Nvidia graphics as the Optimus Overlay tool shows it going from off to on. BUT i also get an error that the driver im using (the solidworks certified driver for my hardware) does not support optimus and i need to use the lastest driver. Unfortunately, I havent found a new driver that gives me stable performance.  Shame, Id really like to be able to use optimus. I use my laptop quite a bit as a web surfer when i stop for dinner, or dont have it docked to the work station.