4 Replies Latest reply on Feb 8, 2013 3:00 PM by Jared Conway

    Flow simulation crashes on generate flow trajectories

    Daniel West

      Hello,

       

      I have succesfully created a flow simulation of my model for the F1 in Schools challenge (Model made in Inventor and imported as a STEP file):

       

      http://dl.dropbox.com/u/41931267/Flow%20Simulation%20FrontUpBackDown.SLDPRT

       

      I can export the global goals and create a surface plot, but as when I try to generate Flow Trajectories, the progress bar remains at 0% and any clicking will result in a crash.

       

      Thank you for your help.

       

      -Daniel

        • Re: Flow simulation crashes on generate flow trajectories
          Jared Conway

          What graphics card are you using? With no files open in solidworks if you enable software opengl from tools > options > systems options > performance > software opengl, does it help?

           

          Does it happen to all files?

           

          Has it ever worked on your system? (what version/sp of solidworks, operating system..etc are you using)

            • Re: Flow simulation crashes on generate flow trajectories
              Jared Conway

              Had some trouble downloading your file and finally got it and took a look. I haven't run the analysis but I wouldn't be surprised if Flow Simulation or SolidWorks would have some issues with it. The imported surfaces all have many errors. Before you perform the surface knit you should fix those. Unfortunately most of that will have to be done manually because the import diagnostics tool was not able to heal all the faces and gaps.

               

              In my experience, if you don't have a robust model, you'll have strange issues like you're facing with Flow Simulation.

                • Re: Flow simulation crashes on generate flow trajectories
                  Daniel West

                  Hey, thanks for taking a look!

                   

                  I'm using the school computers and they lock out pretty mch everything so it's hard to see system specs.

                   

                  I noticed those errors but I didn't may much attention as the flow simulation and surface plot were successful. I know nothing about surfaces, I don't even know why it's coming in as a surface. It was imported from Inventor in a STEP file. The file is fine in Inventor.

                   

                  Any tips?

                    • Re: Flow simulation crashes on generate flow trajectories
                      Jared Conway

                      don't know much about inventor, if they have a model validation tool, i'd run it and make sure that it is fully solid and there are no errors.

                       

                      then i'd try exporting parasolid, step, iges, acis...etc and see if any of them import better into solidworks.

                       

                      once you import, run import diagnostics.

                       

                      repair any geometry that needs to be repaired. setup and run the analysis.

                       

                      my experience is that solidworks is pretty good at importing from other CAD systems, most of the time there is an underlying problem in the other system's CAD model that is only obvious once it comes into SolidWorks. a good test for this is opening it in the other CAD system to see if it opens any better. (export from inventor > import into inventor)

                       

                      There is no guarantee that this will solve the issue, but I'd be concerned about the results of an analysis using bad geometry. I can't check/run on my system due to this issue.