7 Replies Latest reply on Jun 13, 2018 10:55 AM by Azadeh Saeedi

    how do I add new parts to an existing BOM??

    Ryan Hader

      Hey Guys,

       

      I have several drawings that I am revising that have existing BOMS that have external links etc to the parts / assemblies that are called up.

       

      Now I have added a few parts to this overall assembly as well as assemblies and I would like to add these parts / and assemblies to the existing BOM and also add teh external links to those items so that the Balloon feature will also follow any changes made...

       

      How do I add new parts to the existing BOM and add that external link at the same time???

       

      all help appreciated!

        • Re: how do I add new parts to an existing BOM??
          Frank Hewes

          Just open the assembly that was used to make the BOM and add the new components.  The BOM will update to show the new parts, but you will have to add balloons in the drawing field if you want them.

          • Re: how do I add new parts to an existing BOM??
            Kelvin Lamport

            Go to Tools > Options > Document Properties > Tables > Bill of Materials and select Automatic update of BOM.

              • Re: how do I add new parts to an existing BOM??
                Azadeh Saeedi

                Hi Kelvin,

                My BOM in Asm file does not seem to update, even though this box is checked. It updates the details of the files that were part of my Asm file at the time that I created the BOM. However, it does not add new parts to the table. If I create a new BOM now the table is going have 10 more rows. I have Part only BOM setting, and the parts are added to the subassemblies. IS there any way that I  can make sure that my BOM updates all the content?

                Thanks

                  • Re: how do I add new parts to an existing BOM??
                    David Matula

                    The dreaded bom question.  SolidWorks based bom or the old time excel based bom?

                    How many configurations are in the assembly?   Is the bom looking at the right drawing view with the correct configuration that you added the parts?

                    how many parts are just different configurations of other parts?

                    all of these options effect what is shown and how it will display in the bom.

                     

                    I thought that for sure that you could force the bom to update if the auto update was turned off.  I just got the rebuild light on the bom and nothing I tried to get it to update would work.  I turned the option back on and then rebuilt and it did update as expected.

                      • Re: how do I add new parts to an existing BOM??
                        Azadeh Saeedi

                        Hi David, Thanks for responding. The main assembly file only has one Config. The Solidworks BOM setting is Parts Only, and I have the following settings.

                        I have my BOM in 3D Assm file, so I am not sure what do you mean by having it for correct drawing.

                        If I just create a new BOM with the exact setting, my new BOM will show 10 more rows which are for the parts that I added to the sub Assemblies after creating the first BOM.

                        Screenshot 2018-06-13 10.27.21.png

                          • Re: how do I add new parts to an existing BOM??
                            Deepak Gupta

                            Could you check if there are any hidden rows for the existing BOM? Also just curious as why you've this option on

                             

                             

                            Can you share your model files(along with existing BOM and all components) to check? If you can not share them here then send to your VAR (the company you bought SOLIDWORKS from).

                              • Re: how do I add new parts to an existing BOM??
                                Azadeh Saeedi

                                Thanks Deepak, I have Some Sheetmetal parts that I use with some attachment on them and without, so they are one CAD file but different Configs. For that reason "display all config as one item" does not work for me. "Display configs as a separate item" also created some problem with my sheet metal parts.

                                That being said, I do not see any change if I change the settings in terms of including the new parts. I also checked to see if anything is hidden. I will try to contact the VAR as I am not able to share the files.