7 Replies Latest reply on Feb 19, 2013 5:25 PM by Jared Conway

    Flow Simulation Cannot Run or Save document

    Cylo Master

      Hello Everyone.

       

      Ill get straight to the point with the facts

       

      Ive been using Flow Simulation for a few years now. Multiple machine installs since 2007.

       

      Im Working on Solidworks 2011 Sp4,

       

      Updated all my windows 7 64bit drivers and upgraded to service pack sp1. including all relted windows updates.

       

      My pc, more than enough computing power

       

      i7, 32gb ram, ssd drive etc

       

      The problem is................

       

      Soldiworks Runs perfectly including all its addiins, except for Flow Simulation.

       

      Flow SImulation addin loads with no problem, previous saved files can be viewed and loaded.

       

       

      BUTTT......

       

      As soon as i save the file or run the simulation, the whole program instantly crashes.

       

      I am all out of ideas,

       

      Any suggestions would be helpfull.

       

      Thank you

        • Re: Flow Simulation Cannot Run or Save document
          Jared Conway

          where are the files located? double check that the problem happens if the file is on your desktop.

           

          happens to all files? if you make a tube and setup a simple flow-only problem (vel on one side, pressure on other) does the problem still happen?

           

          also i just want to double check, you didn't change operating systems to windows 7 from something else right? you just installed updates for drivers/windows updates?

            • Re: Flow Simulation Cannot Run or Save document
              Cylo Master

              Thank you Jared for your reply.

               

              Well heere is an update so that if someone else experiances this problem.

               

              After serveral more hours of troubleshooting i found the problem but still dont have a solution.

               

              The problem is actually the video card, or video card driver. I have installed Sapphire vapor-x Radeon HD7979 #GB GDDR5

               

              After uninstalling the video driver and running flow simulation on the generic windows driver, everything worked fine. To make sure i tried

              another video card too and everything ran smooth.

               

              I also tried getting an older and newer driver for the 7970 to see if anything changed, but still flow simulation crashes.

               

              I know that this is not a Solidworks supported card, but ive been using high level gaming cards for a while, and this is the first.

               

              Maybe its SW 2011 sp4 does not support it. Possible upgrading to sp5 would fix it or to SW 2012

                • Re: Flow Simulation Cannot Run or Save document
                  Jared Conway

                  From what it looks like, the gfx card is from 2012, the software was developed back in 2010. So incompatibility is not unexpected.

                   

                  Upgrading to the current version might give more compatibility but like you said, compatibility will be limited because it is not a support gfx card for solidworks.

                   

                  So that you don't cripple other apps, you could always leave the current driver and card installed and enable software OpenGL in solidworks. We've seen this help with others running non-pro cards.

                   

                  Also, there is a chance something in your install is broken after all those updates. It might be worth a full uninstall, complete any updates and then reinstall all pre recs and the software again.

              • Re: Flow Simulation Cannot Run or Save document
                Cylo Master

                An update to my intial problem with the saphirre 7970.

                 

                I have purchased two vgas since then.

                 

                Qaudro fx1800. works like a charm.

                 

                Then i got ati W5000. and i get the same problem that i encountered with the 7970 on SW2011 sp4

                 

                Again.. only when flow simulation project is ran or save, it crashes solidworks.

                 

                So i tried to go to performance and select use open gl.

                 

                And problem went away.

                 

                Regardless im still disapointed in getting a high end vga cards that are approved by solidworks and have it not work.

                 

                Obviously the program isnt crashing in open gl mode because its just not using the vga processor anymore.

                  • Re: Flow Simulation Cannot Run or Save document
                    Jared Conway

                    i've definitely had more success with nvidia vs ati over the years but i'm surprised that you still had trouble with the w5000. what driver were you using?

                     

                    for win 7 x64 the solidworks website recommends: http://www.solidworks.com/downloads/videocarddriver/ATI/FirePro_8.982.8.1_VistaWin7Win8_X32X64_146573.exe

                     

                    if you're still having trouble, you should contact your reseller because you have a supported combination.

                     

                    i would also check current versions of the software if you're on subscription. 3 year old software with current hardware is a bit of a stretch.

                     

                    the only thing that we've confirmed at this point is that the graphics card is the issue because you've disabled it with software opengl and the problem has gone away. you could try a full uninstall/reinstall as well but i think it is also strange where it is crashing. I wouldn't expect it to crash because of a graphics card where you're describing. I have a feeling there is something else going on that you'd need to get your reseller involved to better understand what is happening.

                      • Re: Flow Simulation Cannot Run or Save document
                        Cylo Master

                        Thanks again Jared,

                         

                        Yea, i made sure i used Solidworks recommended drivers, even though all vga brands have newer drivers.

                         

                        And adding to your reasoning................

                         

                        Whats strange is that, in what way does flow simulation utilize the gpu on saving and running the simulation. I would imagine it only needs the cpu ram, and hardrive.

                         

                        And yet, when i want to narrow down what the cause is, it goes back to the VGA. i even simply just ran in SAFE MODE, and the flow simulation worked and saving.

                         

                        Logically this makes sense because the vga drivers arnt loaded,

                         

                        Im at a loss.

                         

                         

                        I came to terms that it was possibly a compatiblity issue with 7970. But the same thing happening with the w5000 really lost me.

                         

                        Here is an intresting hardware guide for flow simulation if you would like to refer to.

                         

                        http://www.hawkridgesys.com/SolidWorks-images/hardware_guide.pdf

                         

                        Could it be simply that the newer generation cards arnt supported on this version.

                         

                        But i seriously doubt that there are no other flow simulation users out there who are using new cards on older versions other than me.

                         

                        Most people dont upgrade after 2 revisions but they do upgrade their hardware.

                          • Re: Flow Simulation Cannot Run or Save document
                            Jared Conway

                            Hi Cylo, I completely agree with you. Are we (Hawk Ridge Systems) your reseller? If so I'd definitely get in touch with our support team on this issue. If you can get them an RX, we can take a look and see if there is anything going on that might be causing it and escalate to SolidWorks if necessary.

                             

                            I did speak with the author of that guide. His comment was that we highly recommend using current hardware with current versions of the software. I totally agree with your point of view, but our experience is those that are upgrading their hardware are generally upgrading to be compatible with the latest version of the software as well.