7 Replies Latest reply on Jan 7, 2013 4:44 PM by Tyler McGahee

    All dimensions are invisible - font file broken?

    Tyler McGahee

      Hey everyone. I'm having a pretty unusual issue after installing SW2012 on my new computer. I've included a lot of screenshots to illustrate what's happening.

       

      When I go to make a new part, I click sketch, and, as usual, the three sketch planes show up. However, their names are replaced by "?????????????". (First pic). The names are written properly in the Feature Manager Design Tree.

       

      I click a plane (in this example, the Front Plane). I draw a rectangle with a corner at the origin. I click Smart Dimension, then I click the bottom-most line of the rectangle. It gives me the properties of that line. I click below that line, and the "Modify" box comes up. It does not show the dimension arrows like it should. (Second pic).

       

      I enter a value, and click the check. The dimension is invisible - both the lines and the values. (Third pic). This is still true after I hit the check in the dimension properties box.

       

      Now, after a lot of pain, I figured out what I could do about this. Before I hit the check in the dimension properties box, I can click "Apply the default attributes to selected dimensions" under the Style header. This brings the arrows back. (Fourth pic).

       

      Next, I can go to the "Other" tab in the Feature Manager and uncheck "Use document font" and then click the "Font" button. If I change the font to "Century" instead of "Century Gothic", the dimension shows up. (Fifth pic).

       

       

      Well, I guess I can fix the dimensions, but there's no way I'm going to go through that process for every single dimension. So I change the document properties to have all fonts as "Century" and save it as the template file in C:\ProgramData\SolidWorks\SolidWorks 2012\templates\Part.prtdot . This seems to fix making new parts. I can make a new part, draw a rectangle, and make a dimension that is actually visible. This does not, however, fix the "??????????" names of the sketch planes.

       

       

      Even worse, and more important, though, is that with parts that I've made before (on other computers), with full dimensions and everything, show no dimensions. And it's much much harder to get them to show. Actually, I haven't figured out how to show them.

       

       

      So, my best guess is that the "Century Gothic" font for Solidworks is corrupt. I can use that font in Word 2010, Excel 2010, so I'd guess those were independent (unlike the Arial unicode mentioned in the help files). Does anyone else have a different diagnosis? Or does anyone have an uncorrupted font file, and knows how to replace my corrupted one with it?

       

       

      I've also tried uninstalling and reinstalling (a very slow process as you know) 3 times. I've tried deleting the registry files so Solidworks can make new ones.

       

       

      Thanks in advance for any help you can offer. I really appreciate it. I'll be monitoring this thread, and will be glad to mark a "correct answer."