1 Reply Latest reply on Feb 8, 2013 10:38 AM by Tim Webb

    Old shortcut still works after folder rename

    Melissa Mills

      I have an interesting situation and I’m wondering if anyone else has ever seen this.  About a month ago I renamed a folder in EPDM that contains engineering drawings for a project.  Prior to this one of the engineering leads had created a shortcut to the original folder and placed it on his desktop.  Today we discovered that the shortcut, using the old folder name still takes him to the folder and displays it as the old folder name.  Upon further investigation we saw that it looks like an exact representation of the renamed folder.   However, if you take the path out of the shortcut and copy it into EPDM you receive an error that the folder doesn’t exist.  I have tried to create a shortcut to replicate the problem but receive the same error. It appears that only the shortcut created before the folder rename will do this.   Hope this makes sense.

        • Re: Old shortcut still works after folder rename
          Tim Webb

          Hi Melissa,

           

          I have seen this behavior before.

           

          My conclusion was the folder is a locally cached copy of the folder the user had permissions to view using Windows but when entering through the EPDM interface causes EPDM to try to manage the viewing which throws the error.

           

          Here is the reader's digest version of my current understanding on how the navigation works. Others may know significantly more about this so they can add to this if needed:

           

          1. When the user entered through "Windows Explorer", Windows explorer was managing the interface when the user clicked the old shortcut so whatever folder permissions the user has "in Windows" are active. This activity is not on EPDM's radar.
          2. When the user entered through EPDM (pasted the path into EPDM), the Windows explorer interface is taken over by EPDM so the user has a virtual interaction with the files and folders and navigation to the folder is not allowed since the folder no longer virtually exists.

           

          Sort of like working offline...but not completely.

           

          Hope this helps.

          Tim