11 Replies Latest reply on Mar 31, 2014 12:29 PM by Shane Tully

    Solidworks 2013 Error

    Jon Boyles

      Here is the message we get:

       

      "A journal file could not be created.  Auto recover will not work. Another session of SolidWorks may already be running on this machine." when starting a SolidWorks Session.

       

      When we close a session of solidworks 2013 and open it again, whether it be 5 or 25 minutes later we get the above message.  When checking the processes, even after you close it, sldworks.exe is still running and you have to manually end the process to reopen solidworks.

       

      We are running a Windows 7 64-bit, 16 GB RAM PC with Standalone version of Solidworks 2013.

        • Re: Solidworks 2013 Error
          Steve Staehle

          I have had this problem since day 1 using 2013. ive just learned to deal with it till something came up to fix it

          • Re: Solidworks 2013 Error
            Jeremiah Davis

            First, I would make sure that there is no SolidWorks sessions running in the Windows Task Manager that might just need to be killed.  Then I would check that you have write permissions to the location where the journal file is being written.  The default location is C:\Users\<username>\AppData\Roaming\SolidWorks\SolidWorks <version>\.

             

            You might also see if this folder location has moved from the default by checking the registry key HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks <version>\ExtReferences, the locating the "SolidWorks Journal Folders" key.

            • Re: Solidworks 2013 Error
              Jim Wilkinson

              Hi Jon,

               

              The behavior of sldworks.exe getting stuck running is most often due to an add-in not behaving correctly. Often it is a third-party add-in not provided by SolidWorks since we can easily test all of our own add-ins to make sure this type of problem does not happen with the SolidWorks provided add-ins. So, I would suggest that you turn off any 3rd party add-ins and then exit SolidWorks and see if the process still gets stuck running. If not, then start SolidWorks, turn one of the add-ins and then exit and check again. By process of elimination, you should be able to determine which add-in is causing the problem, if this is indeed the cause. Then you will have to contact your reseller or maker of the add-in to report it, depending on where you get suppotr for that add-in.

               

              I hope this helps,

              Jim

              • Re: Solidworks 2013 Error
                Mike Clinesmith

                Google search shows a number of solutions that point to the registry and indicate to just point the journal file to an existing folder.  I tried thet and it failed.  I had to point it specifically to the folder it was originally created in.  c:\Users\"the user"\AppData\Roaming\SolidWorks\SolidWorks2013.  That is where I found the journal file.  And it now works.

                • Re: Solidworks 2013 Error
                  Peter Farnham

                  If you have Microsoft security essentials running, you can get a bad install than causes this problem.

                  Disable real time protection and then do a Solidworks repair.

                  • Re: Solidworks 2013 Error
                    Maurits Homan

                    I've had this same problem. Just found out that disabling the "Solidworks 2013 Forum" add-in (disable startup) does the trick for me..(!)

                     

                    So:

                    - Disable add-in "Solidworks 2013 Forum"

                    - Exit solidworks

                    - Manually kill the running sldworks.exe process

                    - Startup Solidworks

                    - Shut Solidworks down again

                     

                    Now, the process sldworks.exe should not be running anymore.

                    Try starting a new session, the journal file message should not appear.

                     

                    Good luck!

                    Maurits

                    • Re: Solidworks 2013 Error
                      Matt Packwood

                      Anyone have any suggestions???  Apparently I am the only person at my company with this issue, I managede to use the registry fix in SolidWorks 2012 to change to lcoation of the file to one that worked.... but it does not seem to work in 2013...