4 Replies Latest reply on Oct 25, 2012 5:59 PM by Andrew Brown

    Ctrl+V not working

    Andrew Brown

      So what's the deal with Ctrl+V doing absolutely nothing in SW 2012?  It's incredibly annoying to not be able to copy/paste numbers within SolidWorks.

       

      I can copy text from SolidWorks and paste it in "Notepad" but I cannot copy FROM SolidWorks TO SolidWorks, or FROM Notepad TO SolidWorks.

       

      As soon as I delete the SolidWorks keyboard shortcuts for copy (ctrl+c) and paste (ctrl+v), everything works perfectly.

        • Re: Ctrl+V not working
          Anna Wood

          In what specific area of SolidWorks is this not working?  I use it all the time on drawings and hole charts in SW2012.

           

          Cheers,

           

          Anna

            • Re: Ctrl+V not working
              Andrew Brown

              It wasn't working for copying and pasting text/numbers such as line lengths, angles, etc.

               

              Once I shut off SolidWorks' own shortcuts for them, it started working again.

               

              Most days, I wish I could go back to the 2006/2007 versions, before they added so many annoying new "features"

                • Re: Ctrl+V not working
                  Dean Dickemore

                  Andrew,

                   

                  If I may ring in on this, there is some odd behavior at times with a windows gadget called "Clipboard Manager".  Very handy tool as it preserves data on the clipboard even between workstation shutdowns and reboots.  However it does cause issues at times when attempting to copy/paste with SolidWorks, especially if a partial image may be in the list.  Just thought I would mention this should you be using this particular free utility also.

                   

                  Cheers,

                  Dean D.

                  <><

                    • Re: Ctrl+V not working
                      Andrew Brown

                      Good call Dean!

                       

                      While I don't use any 3rd-party clipboard programs, I did notice that the Microsoft Office EULA would pop-up every time I launched SolidWorks.  After doing the quick registry change to disable the Office Clipboard toolbar, SolidWorks seems to be able to cut and paste without issue.