5 Replies Latest reply on Oct 11, 2012 12:54 PM by Deepak Gupta

    Issues with keyboard shortcuts and Force Regen (Ctrl+Q)

    Thomas Sherer

           So, my department has been running SolidWorks since about 2008, and we always had the functionality to do a force regen (Ctrl+Q) on both a part or assembly. Since we use a lot of external references, it became a relatively good habit and general practice of using it to verify everything was in place at just about any time (assembly, part, and drawing). Due to a bug that misplaces external references, I was forced to remove this Ctrl + Q keyboard shortcut from most of our users' settings. Now, we need to reinstate that functionality, and SolidWorks does not seem to be able to make that keyboard shortcut work for BOTH Parts and Assemblies. I can only define it for one at a time, so we have a perceived loss of functionality. How was it that my shortcut used to be capable of performing two commands and now can only be set for one?

       

      Any ideas or thoughts appreciated. I know I can reload their settings and get them back, but do I even want to do that? Is Ctrl + Q acting as both "Force Regen" AND "force regen the top level assembly" a bad thing that we are just used to having? Maybe a leftover from an older version when they were not separate commands?

       

      Thanks

        • Re: Issues with keyboard shortcuts and Force Regen (Ctrl+Q)
          Deepak Gupta

          Open a new/existing part and set the Ctrl + Q option for force regen and save the part.

           

          Open a new/existing part and set the Ctrl + Q option for force regen the top level assembly and save the assembly.

           

          Now it should work for both the files as required.

            • Re: Issues with keyboard shortcuts and Force Regen (Ctrl+Q)
              Thomas Sherer

              Thanks Deepak, but that doesn't seem possible. When I go to set the second one (the assembly in this case), it throws an error : "Key Ctrl + Q is already assigned. Do you want to change the assignment to Others Force regen the top level assembly.?" If I hit yes it overwrites and only works on assemblies, if I hit no, it cannot regen assemblies. Running SolidWorks 2012x64 SP4. Any other ideas?

                • Re: Issues with keyboard shortcuts and Force Regen (Ctrl+Q)
                  John Sweeney

                  Hi Thomas,
                  There is no straight forward way to restore this particular default shortcut because it does indeed run two different commands.  This is a hard-coded default behavior which is not exposed in our user interface...  As you've discovered, the keyboard shortcuts are not "smart" with regard to which document type is open.  A keyboard shortcut can only be assigned to one system-wide setting unless it is something we've coded into the software.

                   

                  One solution for restoring this default shortcut Ctrl+Q, which runs two different commands based on active doc type, is to use the "Tools-Customize-Keyboard-Reset to Defaults" button.  However, if your individual users have added their own keyboard shortcuts that they wish to keep, then you need to follow the steps below.

                   

                  If you need to maintain other custom keyboard shortcuts:
                  1.  Run the "Copy Settings Wizard" tool, which can be found in your desktop Start bar under "All Programs-SolidWors 2012-SolidWorks Tools".  Use the "Save Settings" option  and then select the "Keyboard Shortcuts" option on the second page. 
                  2.  NOTE - I would also recommend running this tool a second time and saving all your settings with the choices on page 2 so you have a complete backup of all your settings in a .sldreg file before proceeding to the steps below.
                  3.  From step #1, edit the .sldreg file you created by opening it in notepad or similar text editor.
                  4.  Here's where it gets fun.  You need to manually remove all the "11_81" entries and associated "fVirt", "key" and "cmd" entries from the .sldreg file.

                  You will find 3 entries with the "SubArray" text, as seen below, which will only vary by the "tPlate" number.  You may also find 3 more entries with "AddArray" near the end of the key name.  Whether you see these "AddArray" entries will depend on how you defined your "Ctrl+Q" commands.  For example, you will find 3 or 6 sets of info that look similar to this:

                   

                  [HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2012\Customization\tPlate0\Custom Accelerators\SubArray\11_81]
                  "fVirt"=dword:0000000b
                  "key"=dword:00000051
                  "cmd"=dword:00008092

                   

                  In the example above, you would delete these 4 lines from the .sldreg file.  Do this for the other two instances of the "SubArray" found in the .sldreg file and also do it for the three instances of the "AddArray" entries if they are found.  Save and close the .sldreg file.

                   

                  5.  Open SolidWorks and run the "Tools-Customize-Keyboard-Reset to Defaults" action.
                  6.  Close SolidWorks.
                  7.  Now run the "Copy Settings Wizard" tool again and restore the settings by using the edited .sldreg file from step #3.

                   

                  You should now have your Ctrl+Q functioning as if were a newly installed build of SolidWorks. I wish there were an easier way, but I can't think of any for you.

                   

                   

                  Best Regards,
                  John