3 Replies Latest reply on Sep 14, 2012 9:33 AM by Alin Vargatu

    Cannot Access Equations Dialog Box

    W. B

      Hello,

       

      I am attempting to use the equation editor. When I click Tools -> Equations, or right click the Equations folder in the FeatureManager, most everything greys out like the dialog box should be up. The equation box is nowhere to be found.

       

      I am unable to do anything else until I press escape.

       

      Any help to locate the equations dialog box would be much appreciated!

       

      SW2012

        • Re: Cannot Access Equations Dialog Box
          Alin Vargatu

          There is a chance that the equation dialog box appear outside your screen space. To test this assumption, please reset your SolidWorks registry keys.

            • Re: Cannot Access Equations Dialog Box
              W. B

              I believe you are on the right track. I reset the registry keys, and the dialog box does pop up.

               

              Based on this, I know what is causing the problem - the dialog box issue occurrs after copying over settings from the settings manager, even if that backup is from a stock "reset" file that worked previously.

               

              So it would seem the actual act of copying over settings is causing this issue.

               

              Is there anyway to be able to copy settings and still use the Equations editor?

               

              Thank you!

                • Re: Cannot Access Equations Dialog Box
                  Alin Vargatu

                  Copy settings copies registry keys. So the answer is yes, if you spend the time to read those keys and edit or delete the ones that are causing the problem.

                   

                  I tend to stay away from using the Copy Settings Wizard between different versions of SolidWorks. It takes less to re-configure my toolbars than it takes to troubleshoot these kind of problems.

                   

                  You can experiment with limiting Copy Settings to keyboard shortcuts only. Or just eliminate the toolbar option first and see if it works...