2 Replies Latest reply on Sep 11, 2012 4:37 AM by Antony Jude Franco

    problem with creating BOM in Routing

    Antony Jude Franco

      we are using solidWorks 2012 premium for Routing Tool. In there we are creating some sub assemblies (no piping)  and then we will insert them in the main piping assembly.

      after this if we go to drawing and if we took the BOM we are having some problem.

      In piping generally it will save as assembly as a single feature in the assembly tree, which consists of elbows, tee, unions and fittings etc....

      so if we take the BOM if we give parts only in the Title block we can get all the fittings and all the parts in the sub assembly. But what we want is the piping fittings should come as a single part and the subassembly (no piping)  should come like a single name..........

        • Re: problem with creating BOM in Routing
          Peter De Vlieger

          As far as I gather you have a sub assembly with 2 parts in it, which is then mentioned as such in the BOM

           

          One way I can think of is by :

          - right click on the part that you don't want to see mentioned in the feature manager and select properties, in the following window you can select "exclude from bill of materials", this way only 1 will be mentioned instead of two

           

          The other way would be to play around with the config manager on the top level.

          Go to config manager (3rd tab) of the asm with the parts in it and select the top level config (default) with a right mouse click and selecting properties, this should open up some extra options for, amoungst others, the BOM. you can then select show - hide - promote.

          If you select promote on the top level and then do the same for the individual parts but there selecting hide you make it so that only the ASM of the parts gets mentioned in the BOM and the individual parts get ignored while all the individual parts of the actual piping asm keeps getting mentioned.

           

          Hope this works out for you and that it helps.