5 Replies Latest reply on Sep 6, 2012 6:06 PM by Qi Lu

    Cannot exit wireframe-like view

    Qi Lu

      Hi,

      wfme.jpg

      I just started learning SW. After having applied extrusion, extruded cut, fillet and some other operations to the model, and perhaps after inadvertently pressed some hotkey, the solid rendered view of the drawing disappeared. What is left is only something looks like the wireframe view. This cannot be changed even if I choose “shade with edges” or other type in “Display style”.

       

      If I multi select objects, multiple objects are shown simultaneously; however if don’t select multiple objects don’t select any object, then only a sketch or edge of a single base surface is shown, yet in gray color.

       

      Could anyone tell me which mode did I inadvertently activated, and how to revert back to normal view (showing solids, not wireframe)?

       

       

      Qi

        • Re: Cannot exit wireframe-like view
          Glenn Schroeder

          Qi,

           

          Welcome to the forum.  It appears that a sketch is showing with everything else hidden.  You might try clicking on the bodies and see if the icon for Show Bodies is available.  If it's not, and the Hide Bodies icon is available, click it, then RMB again and Show. 

           

          Also, make sure you don't have a sketch active.

           

          If this doesn't work can you post your part?  Click on "Use advanced editor" at the top right of this screen to post files.

           

          Glenn

            • Re: Cannot exit wireframe-like view
              Qi Lu

              Glenn,

               

              They are simply hidden, and clock "show" turns all on.

               

              But I don't know why even if the part is made of several smaller objects, click content menu's "show" or "hide" would instantly apply to all objects. So is this a "global" command for all objects or "local" command that is applicable to individual objects?

               

              Qi

                • Re: Cannot exit wireframe-like view
                  Glenn Schroeder

                  Qi Lu wrote:

                   

                  But I don't know why even if the part is made of several smaller objects, click content menu's "show" or "hide" would instantly apply to all objects.

                  Possibly when one or more of the bodies were created the box was checked for "Merge bodies", so that you now have one body instead of several.

                  • Re: Cannot exit wireframe-like view
                    Jerry Steiger

                    Qi Lu,

                     

                    Show or Hide can be applied at several different levels. I don't actually have SW running right now, so this is coming from memory and may not be completely correct. If you have a single body part, then right clicking on the features in the tree will bring up the eyeglasses that allow you to show or hide the part. If you have a multi-body part, then you will normally get a Solid Body folder. You can right click on the folder to show or hide all of the bodies at once. (Although I don't think it toggles the display of bodies that you have individually hidden.) You can click on individual bodies to hide or show them. You can do the same on parts and subassemblies in your assemblies. You can hide a subassembly or a single part in a subassembly.

                     

                    There are also some View settings that you can change. So you can hide or show individual sketches by right clicking on them in the Feature Manager, but if you have Sketches turned off in the View menu, then none of them will show up. Similarly there is a Hide All Types selection in the View menu that hides everything in the list of types that the View menu controls.

                     

                    Jerry Steiger