2 Replies Latest reply on Aug 27, 2012 9:22 AM by Bernie Daraz

    Drawing Refs not updating

    Craig Cave

      Hi'

      I'm having a probleb changing a drawings referenced model.

      I have an existing drawing which references an assembly.

      I have replaced the original referenced assembly with a new assembly with the same file name. When I open the drawing the views in my drawing show no geometry just a bounding box and X from corner to corner. If I right click on a view I get the option to open the correct model, but the view properties do not show the reference model name and are greyed out.

      I have recently upgraded to SW2012 sp4 from sw2011.

       

      Has anyone got any ideas?

       

      Thanks

      Craig

        • Re: Drawing Refs not updating
          Glenn Schroeder

          Craig,

           

          First I would do a rebuild with Ctrl+Q.  If that doesn't fix it, open SolidWorks Explorer.  Find the drawing and click on it, then click on the References tab.  You should get a list of files that the drawing is referencing.  RMB on them and choose Change.  Change to the desired files.

           

           

          Craig Cave wrote:

           

           

          have replaced the original referenced assembly with a new assembly with the same file name.

           

          This sounds like you changed references by moving the assembly that the drawing was referencing to another folder and replacing it with the new one.  If that's the case, and neither of my suggestions above work, then try reversing this process.