AnsweredAssumed Answered

Update SolidWorks documents using macro

Question asked by Magnus Skoog on Aug 8, 2012
Latest reply on Oct 12, 2012 by Anker Jim

Hi,

 

It's a common problem that the task schedular in SolidWorks 2011 generates very small thumbnail pictures. It seemes somehow resolved in SolidWorks 2012 but for some reason  some files generate thumbnails as they should and some don't. It dosent mather though, SolidWorks 2011 is what is used.

 

I know there is a work around for the problem stated by SolidWorks:

 

-------------

 

he reason for the small thumbnails is that the Task Scheduler runs SolidWorks in a small window - to work around this:

1) make a new task in Task Scheduler – set the task time to be sometime in the future (give yourselves 10 minutes or so)
2) browse to:
%appdata%\SolidWorks 20xx\Scheduler_16
3) locate swbo1.mdb – open this file with Microsoft Access
4) open “TaskListTable”
5) navigate to the column “ExeArguments”  - see the value “/B”  - change this to a “/R”

The “B” parameter tells SW to use a hard coded screen size – if you set it to /R  it ‘should’ use the last used window size – so if the user has SW running full screen – running the macro with the /R should run the update files task with the full screen and should produce the same view with the model in the same place on the screen

 

--------------------

Unfortunately I don't have Access.

 

Do anyone have another solution to the issue? Maybe there is a method to edit the Task scheduler file for a permanent full screen mode or a macro that is able to open a file, rebuild it and save, then head on for the next one by automatic.

 

Thank you for any input, appreciate it

Outcomes