0 Replies Latest reply on Aug 4, 2012 3:56 PM by Brando Dimapasoc

    Fluid not flowing into a cavity in model

    Brando Dimapasoc

      Hello all,

       

      I'm having a problem with a model of mine where fluid does not enter a cavity. Here is a screenshot of the model:

       

      http://imageshack.us/photo/my-images/193/transparentbulb.png/

       

      From this picture, the lid on the left has the boundary condition with a formula-dependent velocity (v=0.005cos(t) m/s), and at the lid on the right is a pressure of 101325Pa. The entire object is 5mm long, and the opening into the bulb is ~1.5mm in diameter.When I run a flow simulation (with blood), this results:

       

       

      Notice how no fluid enters the bulb. No gravity was specified for this configuration. At first, I thought the opening may be too small, so I tried making the velocity at the inlet v=0.0001m/s and specifying gravity to be 10000 m/s^2 in the -z direction, pointing into the bulb. I got the same results, with the flow trajectories merely bouncing off the entrance into the bulb. I was able to find a "fix" for this by creating a lid inside the bulb and specifying a pressure (in the following video, it was 101325Pa). I also turned gravitational effects off. The following video resulted:

       

       

      So now, blood does flow into the bulb. Why won't the fluid flow into the bulb in the first case where i did not specify a pressure inside the bulb? My only guess is that the flow simulation assumes that there is already fluid within the bulb at the beginning of the simulation, resulting in the incoming flow not being able to enter the bulb? In any case, how would I fix this situation? The model is attached below if anyone needs/wants to have a look.

       

      Any help is appreciated!