4 Replies Latest reply on Aug 4, 2012 7:51 PM by Jerry Steiger

    Display datums?

    Amber Brooks

      I cant seem to get the default datums to display in the part or assembly.

      They are set to "Display" under "View" but they still wont show.

      I've tried every setting I can think of but no datums.

      I'm use to pro/e where the datums are always on and you usually have to turn them off. Now that I'm using solid works I miss them

      Any ideas?


      We are using Solidworks Professional 2011

        • Re: Display datums?
          Amber Brooks

          No answers? Really? Nobody in our office could figure this one out either so I had to figure it out myself. I hate it when that happens.


          It seems the only way to keep the default base part or assembly datums to stay on in the model is to right click on them in the feature manager design tree and click the "Show" icon. Then you also have to click view at the top of the Solidworks window and make sure "Planes" is toggled on.

            • Re: Display datums?
              Deepak Gupta

              The reason you didn't got any replies because of the fact that you had the post under API section which means you're looking for a macro to do this.


              Since you've already figured that out, I would suggest you two things:


              1. Move the post under appropriate header/section using the move discussions options under Actions on right side of the post.
              2. Open your file templates (part and assembly) and set the planes, origins, etc. set to show and save the template. This will keep them show for the new files.


              You might also find this post helpful for your future reference

              • Re: Display datums?
                Jerry Steiger



                Once you have things set up the way you like them, save the file as a part template and set that template as the default to be used when you open a file. Then it will always be the way you like it when you start a part.


                Jerry Steiger