3 Replies Latest reply on Aug 17, 2015 12:38 PM by Scott Slovik

    Error on PDM Start (AddInMgr.dll)

    Michael Krinninger

      Dear all,

       

      since we updated our EPDM to SP3 we receive an "AddInMgr.dll" error on PDM-Start, if we confirm this error PDM works as usual but it's "inconvenient" for our users. Google could not really help.

       

      ScreenShot038.jpg

      Our Environment:

      - Windows 7 Enterprise x64/x86

      - PDM 2012 SP3 x64/x86

      - User have local Admin rights

       

      Does anybody know how to fix that?

        • Re: Error on PDM Start (AddInMgr.dll)
          Keith Vittitoe

          Hello.  The solution is uninstall/reinstall epdm - making sure to login as admin.  The message can be different depending on the machine (may reference a different dll) and usually goes away after the first appearance.  This repeated appearance means we need to take another shot at getting the registry cleared up with a reinstall.  You may also consider removing the "PDMWorks Enterprise" registry keys in HKLM and HKCU after the uninstall, but keep clear of any other SW keys.

          • Re: Error on PDM Start (AddInMgr.dll)
            Tim Webb

            Hi Michael

             

            I see this error message often. Keith is right. However another symptom I have encourntered is opening the search window causing this error to appear several times (2x per additional addin installed in the EPDM Admin tool.)

             

            Fixing this requires admin permissions on the computer where the errors are running so EPDM can update the registry (either registering addins or just writing to the registry).

             

            Our IT department is not comfortable with most users having Admin permissions so the compromise is to upgrade the user account to the "Power Users" group in Windows.

             

            Hopefully this helps.

            Tim

            • Re: Error on PDM Start (AddInMgr.dll)
              Scott Slovik

              Hi Michael,

               

              I just had the same issue for 1 user with a new computer, when installing EPDM 2015 SP4.

              Actually, I didnt notice this error right away, because the user was getting a different error

              regarding a custom add-in to EPDM vault. (and experiencing the search window issue Tim described).

               

              The original install was done with the user login. He did have local admin rights to his PC, but I think my

              IS team left the Windows UAC setting enabled.

               

              After disabling the UAC, uninstalling EPDM 2015 client, removing all SolidWorks keys from registry, I reinstalled

              the EPDM 2015 viewer client using my domain admin account. This time everything registered correctly,

              and my user can search in EPDM vault without any pop-up errors.