20 Replies Latest reply on Nov 3, 2018 2:48 PM by Marwan Shehata

    Cannot select or dimension

    Unspecified Unspecified

      I just recently upgraded to the the 2012 solidworks and so far I am experiencing more and more problems.  I needed to edit a bolt pattern on a housing and when I go to edit the sketch it won't let me select any of the lines.  I cannot dimensions them or view any relations on them since they cannot be selected.  Next to my cursor is a dimension symbol but I dont have smart dimension or any for of dimension selected.  I even went and deleted the old feature and tried to create a new one but the same thing happens and I cannot dimension the lines.  Also the program has crashed twice since the hour ive been running 2012 v. 3.0.  This is getting rediculous.

        • Re: Cannot select or dimension
          Deepak Gupta

          Can you upload one example file or some screen shots??

          • Re: Cannot select or dimension
            Kelvin Lamport

            What SW version & SP did you upgrade from?

            How did you install the upgrade? Manual download or SW Installation manager?

            Do you have other versions installed?

            Did you update the video card driver?

            Is your video card supported?

            What are your system specs?

            • Re: Cannot select or dimension
              Scott McFadden

              As far as your not being able to select edges check your dynamic highlighting selection in tools>options>system options>display selection.


              Also did you do a clean uninstall when you upgraded menaing to you completely remove the old version and clean out the registry of any old SW versions?

              • Re: Cannot select or dimension
                Unspecified Unspecified

                I upgraded the actual program to 2012 vs 1.0 on wednesday going through the install manager with the disc.  This morning I uninstalled everything but the install manager and downloaded the 2012 vs 3.0.  When downloaded from their site it opens the installation manager and does the rest through that.  Besides the random bugs and issues I had with 2011, it worked fine but since downloading 3.0 the program has crashed twice and won't let me edit sketches.  My coworker has the exact same setup and everything works fine on his machine.


                The computer is a solidworks recommended hp z400 workstation with an expanded 8gb of RAM.


                Dynamic highlight is on


                It seems as if there is some sort of plane or something in front of the sketch that wont allow me to select the lines.  However if i select Add Relation, it allows me to select the lines.


                Also, not sure if this is a problem, but, I started a new part just to test the program to see if it was something with the part i was working on and when I select new sketch the 3 standard planes all have a series of question marks "?????????" above them instead of "Front Plane" or "Right Plane"

                • Re: Cannot select or dimension
                  Wayne Tiffany

                  Hit F5 to show the filter toolbar and see if you have the dimension filter set.  If so, you can only select dimensions.  Deselect it.



                  • Re: Cannot select or dimension
                    John Burrill

                    Dude, why is your name 'unspecified?'  I'm not calling you unspecified. Until you get a proper name, I'm going to call you, Josh.

                    Josh, let's start with a hardware check.  Launch Solidworks Rx and goto the dianostics tab.  That will tell you if you have any unsupported hardware configurations.  If your machine came with on-board video and a GPU card, make sure that Solidworks is set to use the GPU card.

                    If that checks out then your problem is starting to sound like registry corruption.

                    Try logging on as a different user and launching Solidworks with the default settings and see if you can reproduce the problem.

                    If you can't, then either your Solidworks settings have become corrupted (which does happen occasionally when you upgrade) or your Windows user profile has become corrupt (which does happen)

                    STart with those two things and report back-and get a new user name.  Jeez, you think Depak Gupta could have gotten 10000 freakin points without making sure he had a really cool handle?


                    • Re: Cannot select or dimension
                      Dragos Teodorascu

                      Hello to you all.

                      Since this hasn't been answered yet I will post my issues maybe I find a solution to my problem.

                      I am using SolidWorks Premium 2011 x Edition SP 5.0 (this is the latest SP used in my company and I am not sure when we will upgrade to a newer one but reading most of the post here I do not think it is a good idea since many many problems come out each time a new SP or version is released).

                      I may be a little bit to rude but my patience is running very very low. So the problem I encounter.

                      I had an assembly that was modified, most of the parts were updated and changed. After that going into the assembly drawing of course all of the dimension lost their reference. No problem, it was expected, what it was not expected is SolidWorks not allowing me to re dimension the detail where the missing references occurred. I have restarted SW few times, as well as my workstation with same result. In one detail I cannot select any edge to dimension it. It simply doesn’t want to. All the edges are visible so I am not trying to select some hidden edges or something like that. I have checked most of the selection options and found out that nothing helped. I am feed up with this loosing hours on a stupid thing that was supposed to take minutes (less than 5 to put 7-8 dimensions that lost the reference). I also tried to delete  the detail and recreate it with same result. I CANNOT SELECT AND EDGE NOR PLACE ANY DIMENSION.

                      Please SW experts tell me WHY????


                        • Re: Cannot select or dimension
                          John Burrill

                          Dragos, I remember back in 2011 or 2010 there was an issue with multi-body parts in exploded views, that they would somehow become unselectable.  the remedy in that case was to convert the mutli-body parts into individual assembly components.  I think that problem was solved by the time 2012 came out.

                          Let me ask..can you select and dimension edges inside of the detail circule on the parent view?

                            • Re: Cannot select or dimension
                              Mark Montgomery

                              BINGO!   I'm on 2017 and just ran across a similar issue.  This post tipped me off to the cause and ultimate fix.  I modified a sketch that resulted in a multi-body part (cut all the way across, oops).  Due to various distractions, I didn't tie that to the issue I later discovered.  I could no longer select/edit dimensions in my sketches and a double-click on a dimension would just close the sketch.  The font for dimensions seemed to change size a little and when I dragged a crossing window over the dimension, the handles for flipping arrows would appear at a location on the extension lines indicating the dimension wasn't where I thought it was.  I could delete and recreate a dimension but not edit one. Very odd behavior.


                              When I saw this post, I remembered the multi-body cut that I had later fixed and apparently that was causing the problem.  I went back to my original Boss-Extrude and edited the feature.  Didn't change anything but after exiting, everything is working correctly now.  I'm thinking the multi-body attribute had something 'hung up' so refreshing that original solid feature did the trick.  Just thought I'd drop this here for the next unfortunate soul.


                              EDIT!!! Spoke too soon.  It acted ok for a little while and then back to acting up.  Will update if I come up with a true fix.

                            • Re: Cannot select or dimension
                              Alin Vargatu

                              Dragos, would you be willing to post the file set?

                            • Re: Cannot select or dimension
                              Jan Mellemstrand

                              I have the exact same problem, sw2013 sp3 on windows 8.

                              Can't place dimensions or select lines.

                              All my planes are named ??? both with new and old models.

                              Reinstalled two times.



                              I have been using SW on this computer both on windows 7 and windows 8 earlier without any problems with current hardware.

                              i7, nvidia gtx 570, 8gb ram.

                                • Re: Cannot select or dimension
                                  Evian Davies

                                  Hi Jan, the unknown guy who made this post and all those who have the same problem.
                                  I had the same problem all the time and finally found the fix.





                                  PRESS      V





                                  This is the shortcut key for "Filter Vertices".
                                  You can also turn this off by pressing "F5".
                                  Then deselecting it from the lower toolbar to the far left.





                                • Re: Cannot select or dimension
                                  Jim Sullivan

                                  I had the same problem a few times as well and found out that the filter vertices was accidentally selected.   I didn't know about the shortcut "V" to unselect it.   Thanks Evian for that post.    What I did to easily undo the filter was to keep the Selection Filter toolbar open.   Go to View / Toolbars / Selection Filter.   At least I know when I accidentally turn that on each time.

                                  • Re: Cannot select or dimension
                                    Dave Reens

                                    This is definitely a filter issue. Press F5 to see the filter toolbar which filters what you are able to select. I had the same problem after my cat walked over my keyboard pushing random buttons and enabling the select faces only filter!

                                    • Re: Cannot select or dimension
                                      Marwan Shehata

                                      I'm using *2017*, and I can't get any dimensions captured in the DriveWorks task manager although I enabled *Instant 2D* and *Instant 3D*. Right now I'm playing around with Scissors Lift tutorial I've found in Tutorials - DriveWorks, The problem is that I can see the dimensions, I can select them, but I JUST can't get them added !!!

                                      (However, I can only add features and sketches) , Also as mentioned previously in the discussion, I checked the filters and that wasn't the problem.

                                      Can anybody help?