Shawn Kelly

Convert Task - PDF (Reference Issue SPR 614128)

Discussion created by Shawn Kelly on Apr 25, 2012
Latest reply on Apr 26, 2012 by Shawn Kelly

I would like to get some thoughts and inputs regarding this SPR 614128.


The summary is that if you create user-defined references and try to open the parent document it will automatically cache the child files.


The Problem:

Using the convert task setup an option is to create a reference.  This is in many ways a really good option, but comments above prove it to be a bad option to choose until they fix this SPR.


The idea is to have the PDF file easy to find and open using very little bandwidth or data requirements for non-SW users.  So when someone tries to simply doubl-click on the PDF file it will begin to cache the drawing, assembly, parts, etc...  Image this with a simple 300K PDF file and about 100 MB of reference files over a WAN connection...  This setup has taken something should appear to be painless into something painful.


Our solutoin was to disable the use of references and programatically checkout all the PDF files published, remove the user defined reference and check back in...



The Question:

Do you agree this is an issue?

Have you seen or dealt with this personally?

What do you feel about it?

Should this be escalated to resolve?


Personally, this is a major issue and should be fixed ASAP.  Taking something that is supposed to make PDM easy to find and retrieve data, but making functionality to force the performance to drag is not reasonable.  It certainly impact the users ability to get files quickly and still maintain good data integrity between the parent and child files...


I did log an SR about this and got somewhat of a work around, but certainly not a simple or totally reliable one....


SolidWorks is saying that the only workaround is to check on the user setting: Explorer>Checkout Files when...>The Open command is executed.  When the user clicks on the file, it will launch the check out dialog box where the user will have to uncheck the Get for the references.  You can uncheck the "Check out" box too for the file and it will only get the one file.