40 Replies Latest reply on Aug 2, 2016 1:07 AM by Jacob Sbarounis

    File Corrupt?  Won't save, missing file extension...

    Brian Scruggs

      Hi all, I have a user that has reported a problem to me many times and we have yet to catch the problem in the act.  Well, now we have a live example and I would love to be able to troubleshoot it and help him not lose his work!  Here goes:

       

      The user created a file, 'CHIP PAN.SLDPRT.'  He currently has the file checked out and in use from our Enterprise PDM Vault so I cannot get a copy of the file to distribute here for help.  If he closes the file his work will be lost without a doubt as the time time stamp in PDM shows the last save time over 3 hours ago.  There are a few things 'wrong' with the part and I think they are indicators of the issue but I need help identifying a fix.

       

      1.  The part name, when loaded individually in SW2012 sp1, does not have an extension shown.  All other parts that appear to be working properly do show the extension.

      2.  When the file is force regen'd and saved the 'asterisk' by the name does not go away, indicating it is not saving.  There are no warnings or errors that pop up.

      3.  If you try and close the part it asks if you want to save, if you press 'Yes' nothing happens, the parts stays open but save dailog box closes, again without warnings or errors.

      4.  When you look at the part within an assembly and force regen / save the assembly the save 'asterisk' on the assembly goes away yet when you open the part from within the assembly it is still showing the need for a save and the time stamp in PDM is still unchanged!

      5.  I have verified that other parts save properly so I think we can rule out a connection issue between SW and PDM.

      6.  If I try and 'Save As' it will let me go through the motions but does not save out, either in PDM or outside PDM.

       

      Any help at all is appreciated, I would rather the user not lose his work so let's hear some options!  I tried to search the forum first but came up short, I am sure someone else has seen this!

       

      I have attached a screen cap of SW showing that the file does 'know' where it is stored and you can see the file extension missing from the file name up top.  If there is anything else you need to see just ask, I'll get it.

       

      SW2012 sp1, Windows 7 Pro, Enterprise PDM 2012.

       

      Thanks,

      Brian

        • Re: File Corrupt?  Won't save, missing file extension...
          Jeremy Feist

          the not saving hwen you tell it to and it not saying why sounds like a dis-missed (don't ask me again) message - check his system options to restore any that seem likely - or even those that don't

            • Re: File Corrupt?  Won't save, missing file extension...
              Jim Sculley

              I second this.  I had a user with similar symptoms.  Any attempt to Save As would appear to do nothing.  The dialog box warning you that save as will replace references in any open documents was 'disabled' in Tools...Options...Messages/Errors/Warnings.  That particular message box has two buttons (OK/Cancel) and depending on which button was clicked at the time the Do not show this message again check box was checked, you will get different results.  It had been checked when Cancel was chosen, and voila, nothing happens on Save As.

               

              Jim S.

            • Re: File Corrupt?  Won't save, missing file extension...
              Brian Scruggs

              Nobody with any other ideas to offer up?  I have had the user keep the file loaded since we spotted the issue just so we have a live example in case you guys need me to look at anything, but it has been two days and I think SW would appreciate a reboot!

              • Re: File Corrupt?  Won't save, missing file extension...
                Kenny Whitman

                Did you ever find a solution to this issue? I am having the same exact issue with a small assembly. It was causing so much trouble that I recreated the assembly from scratch with a different file name and the new assembly now has the same issue. This is on the SW Student Edition 2013-14.

                 

                I cannot save the file, I cannot do a save-as (either new name or as a copy), and I crash SW if I try to check the file into the PDMWorks vault.

                  • Re: File Corrupt?  Won't save, missing file extension...
                    Kenny Whitman

                    Also, everytime I try to open the custom properties dialog (file/properties) SolidWorks will crash with this file. I can open and save other files without issue and SW does not crash when I open the custom properites on those files.

                      • Re: File Corrupt?  Won't save, missing file extension...
                        Brian Scruggs

                        Kenny, it has been almost 2 years since I asked this question and I have not been able to find an answer.  I've gone through SW support directly, I've tried the reseller, and these guys here have given me some good tips but they just didn't work to fix the problem.

                         

                        It is a super rare problem for sure, but actually we just had the problem again the other day.  Emailed again for help and got no response.

                         

                        Does anyone out there know why a part would be doing this??

                          • Re: File Corrupt?  Won't save, missing file extension...
                            Scott McFadden

                            Brian,

                            A couple of thoughts go through my head as I read this thread.

                             

                            First, what is the history of this so called corrupted file?  What I mean is since this was the only file without an extension, did it get renamed somewhere outside of vault and then when trying to recheck it in or save it, the system is saying "Wait a minute!!  That is the same as this other part and I do not know what you want me to do with it so I will not save it until you fix this other issue!"

                            If this does happen to be the case, renaming outside of vault will confuse the system, because the links are broken.  It makes me think this because of the missing file extension.

                             

                            Second, Have  you tried using the SW Rx  on this file to see if that reveals anything?

                              • Re: File Corrupt?  Won't save, missing file extension...
                                Brian Scruggs

                                Hi Scott,

                                 

                                First, thanks for the help.  Since we had this just happen again last week I'll give the history of that part, it's simple.  The part was created as new and the user saved it into their folder inside PDM.  As they worked to create features (simple extrudes) they saved periodically.  At a random point the part just stopped saving.  All of this happened over the course of 1-2 hours of continuous work on the part.  We could see the timestamp in PDM of when it was last saved and we checked our system and event logs but nothing registered.

                                 

                                As for the SW Rx, I have not tried that yet and I am not 100% familiar with that process.  Don't you have to restart SW to do that?  If so then the problem is lost when we close the session.  It seems the session goes bad and only for that part, you may could open 100 other parts and they are all ok but that one file is just messed up and won't save.  It's really one of the strangest things I've seen.

                                 

                                Thanks again for the help and I look forward to any advice you can give.

                        • Re: File Corrupt?  Won't save, missing file extension...
                          Raymond Diangelo

                          I have a drawing file that has recently become corrupt. What mine is doing is not letting me save after a few changes were made to some of the seven pages. For me, it turns out it was a particular view or dimension in the drawing. If this happens I suggest closing the file, reopening it, then making one or two changes at a time and save the file every couple changes. This will narrow down exactly what is the problem. My issue was with a certain detail view so I deleted the view, remade and re dimensioned it, and voila... problem solved. Saves no problem now.

                          • Re: File Corrupt?  Won't save, missing file extension...
                            Chris Oxford

                            I've been having a similar experience for several years now. I'll be editing a part or assembly, and SW will crash, and I lose several "saves" worth of parts.

                             

                            This just happened again today, for about the 3rd time this year. Up until now, I never watched the asterisk to check if my saves were taking, forgot about that 10 years ago, kicking myself for not watching that.

                             

                            We are currently using SW 2012 sp5, and Workgroup PDM.

                             

                            I work on checked-out documents, saved to my C-Drive, on a Windows 7 Pro SP-1 64-bit, 3.07GHz, 12.0GB RAM, with NVIDIA Quadro 4000, always latest drivers on everything. This also happens with new parts never checked into PDM.

                             

                            We are upgrading to 2015 this weekend, so this may all be moot, just want to put a stake in the ground with my current experience.

                             

                            (We never upgrade to latest release, as we work in an active production environment, and value stability over latest updates. In order to make this upgrade, we spent 3 years replacing about 50 computers in production, validating all their other functions, all to replace SW Viewer with eDrawings. Then eDrawings proved to expensive and processor-hogging, so we're going with PDF's for production viewing.)

                            • Re: File Corrupt?  Won't save, missing file extension...
                              Jacob Sbarounis

                              I work at Hino Motors and we use solid works a lot, I have had this issue a couple times and what I just figured out was that you can email the file to yourself then click on the attachment after you emailed it to yourself and save-as another name and the file was actually saved from the time you couldn't save it. I tried to do another save as just from the drop down file menu and open it and that doesn't work. For some reason emailing it worked.

                              So, go to the drop down file menu, click send to..., then on the pop-up click the .SLDDRW only option at the top, then ok. Once the email is sent to you right click, save-as with another couple characters (copy,2, etc.), and save to your desktop. Then you can open and continue.

                              Another thing that worked if you are done with your drawing is save it as a pdf which worked fine for me before all these steps.

                              -Jacob