4 Replies Latest reply on Mar 26, 2012 8:54 AM by robert dattilo

    SW blocks, lacking?

    robert dattilo

      Hello;

       

          This just seems a bit weird, I have a drawing; in which i have a preliminary stamp, (See attached files).  I've just tried to make a block of this re-usable stamp by grabbing it, & doing a save as block. When I save what I have, I lose the text, the line gets much thinner, and changes color. The rectangular shapes ok. This just doesn't seem like they've maximized the efficientcy of knowing what we would desire, when we create a block. As I debate whether to just copy & paste this from a standard drawing, or work through 3 out of the 4 aspects of this block I'd appreciate any thoughts or input.

       

      Thks, in advance;

       

      Rob_D SW 2012, sp1

        • Re: SW blocks, lacking?
          Wayne Tiffany

          I just tried it in your drawing and it seemed to work fine.  The upper one is the block I created by highlighting all and clicking the Blocks toolbar Make Block icon.  The lower one is the one you had made.

           

          I am on SW2012 SP2.

           

          WTPrelim block.JPG

            • Re: SW blocks, lacking?
              robert dattilo

              Hello;

               

                  Thanks for the reply. I guess what I was thinking was to save it as a block, which is what I did. I did that because I'd like to keep it in a blocks folder, & insert it, into any desired drawing. That's when I got the rectangle only. I just tried make as a block in the drawing & the only issue I still had was the color changed.

                  Are you saying first create it in the drawing as a successful block, & then save it out as a more universal block, out in a folder? I thought saving it as a block would do the same thing as make block.

               

              Thanks,

               

              Rob_D

                • Re: SW blocks, lacking?
                  Wayne Tiffany

                  Ok, here's a solution, maybe.

                   

                  Modify your drawing layer textred to have the thick line.  Save out the block.  Insert the new block into the drawing.  When you put it on the textred layer its lines go fat again.

                   

                  WT

                    • Re: SW blocks, lacking?
                      robert dattilo

                      Hello Wayne,

                         Yeah, that did work for me, & I expected maybe some layer issues, but I re-checked this also, and if you save as a block, which it gives you the option, you just get the rectangular sketch no text etc., If you first make a block of it; then save it as a block, the text will be there.     

                         Possibly something that would steer people a little better would be when you select the entities, if you could only have the ability to make a block, not save it, and then when you select a block, you'd have the option to save as a block. Better yet, if when you select save block, SW, would first make it into a block, if that's the way it works, & then save it as a block flowing with your intent. 

                       

                      Thanks much for you input.

                       

                      Rob_D SW2012 sp1