8 Replies Latest reply on May 25, 2012 7:24 PM by Tim Webb

    Template Serial Numbers

    Kevin Stickels

      OK, I give up! I created a folder card and template to autogen projects. Everything works fine except the Serial Number.  The Serial Number is formatted as such;

       

      LE-PROJ-"Counter-05"  (Type is "Serial Number from string")

       

      Pretty simple and basic. However, when I create a project, I have to go in each time and reset the Serial Number. This morning I created a project 15215. When I went into the Serial Number tab in Admin, it indicates the next counter value is 15231...I checked the template file and the tab for "disable serial number generation" is set. Anyone have any ideas???

        • Re: Template Serial Numbers
          Stephen Lapic

          I remember having a problem with it incrementing by 2 each time.  I figured out that I had it in the file card for the document and in the template that created the document.  I left the one in the file card as is but the one in the template I changed to a variable instead of a serial number.  Works fine now.

           

          Yours jumped by six numbers.  Is that consistent?  Possibly somewhere you have a couple loops that keep increasing the serial number that you will just have to slowly track down.

          • Re: Template Serial Numbers
            Joy Garon

            Hello Kevin -

            When you are dealing with folders, there is no "disable serial number generation" option.

            You need to edit the folder datacard and set the project number field to NOT use a serial number. Instead, use text value.

            Regards,

            Joy

            • Re: Template Serial Numbers
              Alison Hilditch

              I'm having a similar problem with Serial number incrementing between @ tab and Default tab part number variables. Is the fix similar to that listed above? I have only one template card with the 'From Serial Number" button checked and the corresponding file card pulls a text value.

                • Re: Template Serial Numbers
                  Stephen Lapic

                  Alison;

                   

                  If you are saying that one tab is incrementing and the other is not then I would check the Updates all Configurations box on the card for that variable.  If you are saying that both increment but at different rates then that is weird and I have no idea.

                    • Re: Template Serial Numbers
                      Alison Hilditch

                      They are incrementing at different rates which I thought was weird too. The serial on the @ tab will say 20002 and the default value will be at 20003. I 've remade the templates and double checked what boxes are checked, but to no avail. I was thinking that maybe I could have the default override and then maybe the values would be the same.

                        • Re: Template Serial Numbers
                          Alison Hilditch

                          Okay! I got it fixed for the most part! Woo! I really wish I could tell you exactly what I changed to make it work, but, in the end, I neuked the cards and started again. I'm sure it was a discrpancy between the template and file card settings, though I'm not sure which ones. Now I just have issues between the @ Tab and Default Tab. Variables show up on one, but not the other (like Mass, which is mapping to SW propperly, it just doesn't show up in the @ Tab at all). Perhaps someone could enlighten me on the necessity of  the Default tab, I know it's for configurations of sorts, but why I need it messing with my metadata mapping is beyond me. I can't find reference to it in my guide.

                          Thanks!