AnsweredAssumed Answered

Sketches/part hidden, but still present?!

Question asked by Ben Frearson on Mar 6, 2012
Latest reply on Mar 7, 2012 by Ben Frearson

HI,

 

I created a set of drawings using our regular template for an assembly. I noticed something was odd when I was dimensioning the model, and the dimensions would sometimes snap and dimension points that weren't visible in the view. I initially ignored it as something to look at later.

 

However, when I exported the drawings as DWGs, there were a load of sketches present which weren't shown in the SW drawing.

 

All our models are driven from a skeleton part filled with sketches. This is inserted into an assembly, and features are driven from this skeleton part. When I created the drawing, I hid the skeleton part within the assembly, which is what we normally do. It looks like the sketches though, are persistently there, regardless of whether the part is hidden or shown.

 

The part is also set to hidden in the drawing view properties, so I don't understand why the sketches are still present.

 

 

As a test, I showed the skeleton part in the assembly, and the drawing now shows the sketches, even with the part hidden (selected in the "Hide/Show Components" tab in the view properties). I can select each sketch and hide each one in turn, but I don't want to do that, and we have never had to do that before. Also, suppressing the part stops the sketches appearing in the DWG (which is my workaround for now), but doing this indicates that some of the drawing dimensions snapped to the invisible sketches, rather than the features they were driven from, so they lose their references. I thought it might be the "show hidden edges" option, but that isn't available for the skeleton part when I RC it. Presumably because there are no features/bodies in that part, only sketches.

 

What I think may be happening (I may be wrong), is that the sketch visibility isn't being affected by the part visibility in the drawing. The model behaves fine, and the visible sketches aren't the converted ones in the features (there are some sketches that aren't driving anything which are visible).

 

I thought it might just be a setting, but I can't seem to find anything that could make it do this. My collague and I are both stumped. I've contacted my VAR, but I thought it'd be worth asking here too.

 

Thanks

Ben

Outcomes