AnsweredAssumed Answered

Assembly does not refresh after opening a part - Resolved

Question asked by Computer Services on Mar 2, 2012
Latest reply on Mar 2, 2012 by Scott McFadden

I am not a regular SolidWorks user - I work in the IT department (please don't hold that against me - ). I hope I can describe this problem correctly so someone may have an idea how to resolve it.

 

One of my SolidWorks users (running on an HP Z600 workstation, Quadro 4000 graphics card running the latest SW approved drivers, SW 2011 SP5, 12GB of RAM) opens an assembly. Everything comes up fine. He then right-clicks on a part and opens that to look at it. Even if he makes no changes to the part or the assembly, when he closes the part, the entire assembly 'disappears' or won't refresh. It looks like it is trying to display the assembly again, but it can't - we just see a grey screen. If he maximizes the window, it will show up again but when he restores the window position it disappears. This happens with any assembly he opens.

 

I had read one other article that one person mentioned it could be due to the second monitor. We tried disconnecting the second monitor from his computer, but no joy.

 

I am attaching some screen grabs - one shows the assembly when it is open, the other when we open a part, and then how it looks when we close the part. One other thing to note is this seems to happen as well if we try maximizing the SolidWorks window. When we restore down it goes back to normal. To me this screams video or graphic issue, but the person doesn't have any other issues or screen flickering / jumping / weirdness. I have checked event logs, made sure he isn't running any other programs, checked video settings in the nVidia control panel to make sure he is using the SW profile, everything I could think of.

 

Has anyone run into this before, or have any ideas as to how we might be able to fix this? Thanks for any suggestions.

 

Rob

 

 

 

EDIT:

 

Hi Scott,

 

Thanks for the info. We did try a ctrl+q as a first step but that didn't seem to help, and he did do a live Rx session with our VAR who sent the info to SolidWorks - they came back saying it was a video issue.

 

I think we may have found the solution though....

 

One file the person was working on came from a sister company, and for some reason they had the 'Command Manager' window open while creating the drawing, and saved it that way. When the person here opened the file, for some reason when he went in to look at or edit a part in the drawing, this command manager opened across the entire workspace, covering everything. It seems this setting then ended up being saved across any file he worked on, so every time he opened an assembly and then a part, this command manager would open again.

 

He has figured out how to close this, and everything seems OK now. On to the next issue!

 

Again, thanks very much for your suggestions.

 

Rob

 

Message was edited by: Computer Services

Outcomes