AnsweredAssumed Answered

Problems with deploying SW from a Windows 2008 server

Question asked by Steve Visser on Feb 23, 2012
Latest reply on Feb 24, 2012 by Steve Visser

For years I have deployed SW admin images from a 32 bit Windows Server 2003 and, since it was a 32-bit server only, also used a 64-bit Windows workstation to deploy 64-bit SW.  I deploy sharing a folder containing the images, going to the client stations and mapping a nekwork drive letter to the server shared folder and then just running the .hta file in the admin image folder.  Everything has always worked fine.

 

Over the holidays we installed a new server with MS Windows 64-bit Server 2008 with the latest SP's, so that we could deploy both 32 and 64-bit SW.  While creating the first 2012 SP2 admin images, I found I needed to have the .net framwork Role installed which I did.

 

After several botched attempts, I finally got SW images created for 32 and 64-bit installs.  I used the Options Editor to set an install path on the clients as well as having the image run the settings registry file.  The 64 bit image installed fine on the server itself and on my own 64-bit client.  Since half the SW clients are on a separate network, I then copied the admin images over to a different 2003 server on that network and have successfully deployed about 8-10 32 and 64-bit clients on that network.

 

Back on the first network, I then went to install more clients, both Win XP and Win 7, and every install failed.  The Installation Manager would start and almost immediately fail.  I checked the usual issues with IE with ActiveX permissions, even checking a couple extra boxes when the required ones didn't resolve the disappearing issue.  Still didn't work.  After much chatter back and forth with our VAR and with SolidWorks, in the Options Editor, I turned off the function for installing the settings file.  Then it started working again and successfully installed  5 more clients on both Win XP and Win 7.  Later, I went to install on a Win XP laptop and it failed again.  I also copied the original images I had of SW 2010 over to the 2008 server and they also are failing.

 

So right now I have admin images that deploy fine on a network from a Windows 2003 server.  On the other network, it's hit and miss from the Windows 2008 server.  My question is: is there some other roles (or whatever additional modules) that need to be installed on the Windows 2008 server?  Could there be permission problems?  I know the 2008 server has a lot more security on it but I've got the share wide open and the installs still fail.  I must be missing something but have yet to figure out what and it seems we don't have any MS 2008 server experts in our company, our VAR, or at SolidWorks.  If it was the images, then it seems they would failing on the second network.

 

Any ideas would be greatly appreciated.

Outcomes