AnsweredAssumed Answered

Solidworks 2011 used to work before without software OpenGL

Question asked by S. dw on Dec 7, 2011
Latest reply on Feb 16, 2012 by S. dw

Hi all,

 

I've been busy with this problem for some days now:

 

Solidworks 2011 used to work fine until a couple of days ago. When opening an existing part (and solidworks) the program hung. After trying a couple of times I managed to open a new part. Afterwords I worked for something like 4 hours in SW without problems.

The next day when trying to open a part the same problem occured: the program hangs. It is using 100% cpu (1 of my 4 cores), the memory stays the same.

I am able to open a 2D drawing and the basic program without opening a part or assembly.

After looking on the internet, I tried to thick on: "Use software OpenGl". After which I am able to use the program, but much more slowely. I tried the following:

 

- Updating video drivers to latest (clean installes)

- going back to previous working drivers

- repaired solidworks

- reinstalled solidworks

 

The problem persist. I can't use SW anymore without Soft OpenGl.

 

My system:

 

Intel Q6600 (2.4Ghz)

4*1Gb pc 8500

POV Nvidia GTX 460 SSE2 1 Gb

Asus P5Q-D Turbo

lots of hdd's etc...

 

OS: Windows Server 2008 R2 x64 with all updates

SW: Solidworks 2011 x64 SDK Sp 2

 

solidworks crashes.jpg

 

I installed "OpenGL Extension Viewer" . My OpenGL versions is 4.2. I did some rendering test with that.  No problems there.

So I'm puzzled. I did not install any new software or updates when the problem started to occur at first. First time it occured i managed to work around it by opening a new part. Any help would be appreciated.

Outcomes