11 Replies Latest reply on Dec 11, 2012 5:23 AM by Neil Attrill

    Cannot set EDrawings as default program for .dwg files

    Dan Labonville

      I am running SW 2012 64 bit on win 7 64 bit os and I cannot get EDrawings set as the default program for .dwg files. I sent this to support a while back and they were not able to resolve it.

       

      I had the same problem after updating to sp2 in SW 2011, but it worked fine before that. I can open edrawings and then open the .dwg file with no issues, but cannot make it the default program.

       

      I am aware of HOW to set default programs. I cannot get edrawings to be the default. It is not listed in available programs for file association. If I browse to it and select it nothing happens.

       

      Any suggestions?

       

      Thanks

      Dan

        • Re: Cannot set EDrawings as default program for .dwg files
          Wayne Matus

          What happens when you double click on a dwg file in Windows Explorer? Does it open the file in another application?

          • Re: Cannot set EDrawings as default program for .dwg files
            Ravi Teja

            Hi Dan,

                       Does DWG files open with Someother applications.If so,Right Click on any DWG files,Go to Properties, On GENERAL TAB click on Change buttom and Select eDrawings from the list or browse to it.

             

             

            Hope this helps

             

             

            Regards

            Ravi T

            • Re: Cannot set EDrawings as default program for .dwg files
              Dan Labonville

              Thanks for the replys.

              Solidworks is the current default for .dwg files. I can change it to other programs but not edrawings for some reason.

              • Re: Cannot set EDrawings as default program for .dwg files
                Allan Georg Jensen

                Hi

                I got the exact same problem.

                You can't solve it by going into Explorer -> Tools etc. because you can't choose EDrawings from the program list.

                It's simply not there...

                 

                Even though I browse and finds the EDrawings .exe file it still won't associate :/

                I got the issue on both WinXP and Win7.

                 

                I had no such problem with the 2010 version, but now since I upgraded to 2012 this problem started.

                 

                The question is, is this a SolidWorks problem or a Windows problem?

                • Re: Cannot set EDrawings as default program for .dwg files
                  Allan Georg Jensen

                  Thanks for the answer but "old school" doesn't work in this case...

                  I tried it many times but edrawings just won't associate even though I browse for the .exe-file and just "Always use...".

                  The file will NOT open with edrawings but selects the next program on the list, usually it's Adobe Reader :/

                   

                  This method is a no go...

                   

                  /Allan

                  • Re: Cannot set EDrawings as default program for .dwg files
                    Cory Miller

                    I have had the exact same issue on several computers since upgrading versions. After researching for quite some time I found the answer at least for my systems. It appears the software install of newer versions is not replacing the older "pointer" to the open command in the registry with the new location.

                     

                    You can verify this by opening regedit and going to "HKEY_CLASSES_ROOT\Applications\EModelViewer.exe\shell\open\command".

                    I had just installed the 2013 version and when I looked on one system it had "C:\Program Files\Common Files\eDrawings2011\EModelViewer.exe" "%1" for the entry. This was one of the previous versions I had installed but since removed. Just as in your case it is not listed in available programs and if you browse and select it nothing happens.

                     

                    When I chose to modify the registry and replace the 2011 folder name with 2013 ("C:\Program Files\Common Files\eDrawings2013\EModelViewer.exe" "%1") everything started working and it now shows in the available programs. I have since had three computers each had different versions listed in the registry key which worked after applying this change. As always please be careful when editing the registry.

                    /Cory



                      • Re: Cannot set EDrawings as default program for .dwg files
                        Allan Georg Jensen

                        Thank you a million Cory

                        Finally someone cracked this one; you've made my day, month or even year with this solution.

                         

                        So simple, yet so hard to come by.

                         

                        This worked a treat

                         

                        Thanks again

                        /AG

                          • Re: Cannot set EDrawings as default program for .dwg files
                            Neil Attrill

                            I had the same problem with 2013 and XP, but couldn't find the right part of the registry (or don't have permissions at work?). Anyway, I found another way to do it.

                             

                            • Go to Folder Options > File Types.
                            • Find the files you want to assosiate (SLDASM, SLDDRW and SLDPRT).
                            • Click 'Advanced' (If you had inadverantly assiosiated with the wrong file type, click 'restore' first).
                            • Click 'Change Icon' and browse to the edrawings exe file. Click ok to come out of the Edit File Type dialog.
                            • Go back into 'Advanced' (you have to come out and back in to make it work for some reason).
                            • Click 'New'
                            • Type 'open' under 'Action:'
                            • Browse to the edrawings exe file and select it.
                            • Leave 'Use DDE' un-checked, and click ok
                            • Click ok to come out of the Edit File Type dialog.
                            • Go back in to make sure the changes happend. Sometimes it seemed to delete it for me, but be persistant and do it again if not there.
                            • Repeat for all file types.

                             

                            It's a bit of a pain, but it worked for me. The edrawings exe file was under C:\Program Files\Common Files\eDrawings2013\EModelViewer.exe