4 Replies Latest reply on Feb 8, 2012 9:11 AM by Brendan Labrecque

    Excel application error when creating goal plot from Flow Simulation

    Brendan Labrecque

      I am trying to add a Goal Plot from the results tab in SolidWorks Flow Simulation.  I've done this successfully before, but I am now on a new 64 bit computer.  I am using SolidWorks 2010 sp4.0

       

      1. add the goal plot from results tab

      2. excel opens up as it normally does

      3. the spreadsheet starts to populate with data

      4. then an error messages pops up (see attached)

       

      I "enabled all macros" in excel options, but this did not help.  I need ideas on what to attempt to fix this issue.


      Thanks

      Brendan

        • Re: Excel application error when creating goal plot from Flow Simulation
          Aaron Shaw

          I am struggling with this exact error also.

           

          The error message reads:

           

          Excel application error:

          Cannot run the macro ''goals1'!DisplayData' . The macro may not be available in this workbook or all macros may be disabled.

           

          Not sure what to do...any helo would be great!

          • Re: Excel application error when creating goal plot from Flow Simulation
            Mike Dumesh

            Same error here. My company's default Excel policy is to disable all macros, and I thought that was the cause of this error message. I am having them change my Excel preferences, but reading the original post it doesn't look like it's going to help.

            When I had Windows XP on my machine, everything was working fine. The error started appearing after I upgraded to Windows 7.

             

            SolidWorks, hello, anybody reading these?

              • Re: Excel application error when creating goal plot from Flow Simulation
                Mike Dumesh

                OK, I figured it out on my end. Maybe that will help you guys.

                 

                Open an excel spreadsheet. Go to the stupid big button in the upper left corner, I think they call it START button. Hit Excel options->Trust Center->Trust Center Settings. Go to the "Trusted Locations" tab. Then click on "Add new location..." button, and go to your Solidworks installation directory. Note, if you are on a 64 bit machine like me, you have a SW install directory under Program Files (x86) and under Program Files. Select the directories in both locations. If you only select the one under Program Files (x86) this will not work (as I found out the hard way). Also, check the "Subfolders at this location are also trusted" option when the "Add new Location" window is up.

                 

                Hope this was helpful.

              • Re: Excel application error when creating goal plot from Flow Simulation
                Brendan Labrecque

                Template for goals is located here:

                Program Files\SolidWorks Corp\Flow Simulation \lang\english\template\Goals

                 

                Windows:

                1. Makes sure you can open up the excel template in its location without any issues

                Excel:

                1. Add path to trusted locations from Excel as Mike Dumesh figured out in previous post
                2. Enable the ASAP utilities in Excel:
                • Close Excel if it is open.
                • In the Control Panel choose "Add or Remove Programs" (or Programs and Features in Windows Vista).
                • Select Microsoft Office in the list and click on the Change button.
                • Choose "add or remove features"
                • Select "Visual Basic for Applications" in the "Office Shared Features" list and set it to "Run from My Computer". Then click on the continue button.
                • After the installation is finished you will be able to use ASAP Utilities when you start Excel and see ASAP Utilities in the menu.

                 

                source: http://forums.techarena.in/operating-systems/1152398.htm

                 

                Good Luck!