8 Replies Latest reply on Oct 3, 2011 2:14 PM by John Sweeney

    View Layout problems...

    Stephen Wilson

      Late last week I was moving around some of the toolbars on the sketch window and I lost one that I use most frequently, and now I cannot seem to find how to restore it on the Solidworks window.

       

      Its the tabed one that reads "View Layout, Annotation, Sketch, Evaluate, Office Products"

      I used that toolbar constantly going between sketchviews, evaluate (which was extremely helpful for doing Mates in Assemblies), and Assemblies.

       

      Any suggestions on how I can change my view from this:

       

      IMG_20111003_083200.jpg

       

       

      To this:

       

      IMG_20111003_082409.jpg

       

      Thanks for your help!

       

      Dyno Steve

        • Re: View Layout problems...
          Richard Doyle

          Hi Dyno Steve,

          Open a file, right click in the top menu bar, and select "Command Manager".

           

          Richard

            • Re: View Layout problems...
              Stephen Wilson

              It did not show the toolbar that i am trying to get on the screen.  All that changed was the sketch and feature toolbars showed up, but that tabbed menu that I am looking for is still not visible.

               

              Thanks for your help though.

                • Re: View Layout problems...
                  Richard Doyle

                  Okay...let's try this.

                   

                  Right click on the top menu, then selet "Customize".  You should be able to see the Commmand Manager tabs now - right click on one of them and select "show tab".  Exit the customize screen and one tab should now be showing - right click and select all of the tabs you want to see.

                   

                  Richard

                  • Re: View Layout problems...
                    John Sweeney

                    Hi Steve,

                    If you're still not seeing the CommandMgr at all, then its possible you unintentionally undocked it and it is positioned somewhere on your screen where you can't see it.  This can happen if you change your monitor resolution or unhook a second monitor in a dual monitor setup.  In the latest versions of SolidWorks, floating windows should behave better if they end up off the screen, but SW2009 will not self-correct the issue.

                     

                    You can try two things:

                    1. Increase your monitor resolution so it shows more graphics real estate.  You may then be able to see the commandMgr window.  If it is in "auto-collapse" mode, you may only see the window header.

                    2.  If you're comfortable editing the registry, then do the following:

                             1. Close all running versions of SolidWorks.

                             2. Open the registry editor using the "regedit" command from a command prompt (or find the program in Start menu)

                             3. Expand the "HKEY_CURRENT_USER" key and rename the:

                                     "[HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2009\User Interface\CommandManager]"

                                  registry key to something like: 

                                     "[HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2009\User Interface\CommandManager_test]".

                     

                    When you restart SolidWorks, it should use factory default values for the Command Manager.  Note - This will cause you to lose any customization you may have done in teh CommandManager with regard to tabs or buttons you've placed on it.

                     

                    Hope this helps,

                    John

                      • Re: View Layout problems...
                        Stephen Wilson

                        That Worked.  Thank you so much for your help!

                         

                        Now I can get back to my previous productivity and not waste so much time hunting and searching for icon and features...

                         

                        Thank you so much for your help Mr. Sweeney! 

                         

                        P.S.   Now can I rename the CommandManager_test back to CommandManager and will it keep the view how it is now?

                         

                         

                        Regards,

                         

                        dyno Steve.

                          • Re: View Layout problems...
                            John Sweeney

                            Glad it worked.  Before renaming the "CommandManager_test" back to "CommandManager", do the following:

                             

                                 1. Start up SolidWorks 2009.

                                 2. With the CommandManager toolbar visible and docked, undock it by clicking on "dead space" between buttons and drag it onto a visible location on your screen.  Do not double-click to undock it or the floating toolbar may end up off your screen again.

                                 3. Release your left mouse button so a new floating location is fully established for the toolbar.

                                 4. Now redock it by double-clicking it or dragging it to the desired dock location.

                                 5. Close SolidWorks.

                                 6. Rename "CommandManager_test" registry key back to "CommandManager".

                             

                            The reason we want to perform the steps above is that the floating location of a toolbar is stored in a different location of the registry.  I believe you have bad data in this part of the registry which is causing the floating location of the CommandMgr to be off-screen.  Doing the steps above will make it "proper" so this doesn't bite you 6 months from now if you double-click to undock the CommandMgr.

                             

                            Best Regards,

                            John