2 Replies Latest reply on Oct 11, 2011 3:52 AM by Kishore Garakipati

    Custom Properties Showing Text Expression Instead of Evaluated Value

    Jared May

      I have created a custom property that creates a part number based on the file name and configuration name.  The custom property is Manufacturer # shown below.

      custom properties.JPG

      The custom property menu evaluates the expression.  However, the EPDM BOM shows the text expression instead of the evaluated value (shown below).

      BOM.JPG

      How can I have the BOM show the custom property evaluated value?

        • Re: Custom Properties Showing Text Expression Instead of Evaluated Value
          Jeff Sweeney

          I've seen that quite a bit...never understood why. Though it seems to go away the second time I check the file in.

           

          Since you are using the configuration name, you may have to activate that configuration and rebuild it to get EPDM to resolve.

           

          If you figure out what causes this, please post back. I'd love to know.

          • Re: Custom Properties Showing Text Expression Instead of Evaluated Value
            Kishore Garakipati

            In early versions & service packs of EPDM 2008, I found the reason for the mentioned issue.

             

            While the SW file custom properties are being reviewed during "Checked-Out" state, I too found the EPDM data card would only show custom property expression instead of evaluated value.

             

            The moment when the SW file gets checked-in, I found the issue is resolved. I mean the expression is evaluated during Check-In time and then EPDM showed the evaluated value.

             

            So, I think this issue seems similar to me as mentioned above. So I would suggest to conduct such EPDM actions (Check-In/Check-Out, Get latest version, rebuilding the file in SW application etc...) to see the difference in results between multiple EPDM operations, thereby you might be able to identify the real reason for it.

             

            If the issue persist during every EPDM operation, then it could be treated as bug and you might need to work with your VAR/SW directly.

             

            Hope this information helps....