3 Replies Latest reply on Aug 19, 2011 1:42 PM by Bill Rose

    "Configure Feature" not working properly in 2010?

    Bill Rose

      I'm on SWx 2010 SP5.0.

       

      I have had a bunch of problems with "Configure Feature". I RMB click a mate or other feature which brings up the dialog showing all the configurations and the state of those in regards to being or not being suppressed. Unlike 2008, 2010 actually sizes the dialog so you don't have to drag it larger each time you use it. Progress! Except it now offers to manage the suppressed states but doesn't. In 2008 it worked, in 2010 it seems to be broken.

       

      Here's today's example;

       

      I suppressed a mate in one configuration with the intention of only doing it in that one configuartion and not make a global change. Well, all the configs now have the mate suppressed. No problem, RMB click, select "Configure feature" and the dialog shows that only the current config is suppressed. It lies. They're all suppressed. So I unsuppress the current config and click "Apply". The mate in the current config is now unsuppressed but the others are still suppressed. OK, let's try again, this time I'll check and uncheck each one, then click "Apply". No joy. This was a handy feature when it worked. Before we had this tool we could pull up the features properties and change the suppression state of each configuration easily by using the "This configuration", "All configurations" or "Select configurations" options. That's no longer possible. I'm now doing each one manually and it's making me crazy.

       

      I don't use design tables, these are just configurations created one at a time. What's my problem with this command? I'm stumped.........Bill