21 Replies Latest reply on Jul 28, 2011 11:03 PM by Martin Retzolk

    Disappearing drawings

    Martin Retzolk

      I have been working with my files for a while, but when I tried to open them this mornig nothing is showing up except for the sheet border, however when I hover the mouse over the sheet tab and also in the preview window before opening the drawing the items on the sheet show.

       

      Can someone tell me how to adjust  or fix this issue, please?  I am still faifly new at this and am not experienced enough to troubleshoot.

       

      Thanks for any help given,

      Martin

        • Re: Disappearing drawings
          John Lindemann

          Somehow the link between your drawing and the model has been broken.  Most likely causes:

           

          The name of the model or drawing has been changed

          The file of the model or drawing has been moved

           

          The only solution I can think of is to use SW Explorer to "replace" the old file with the new file.  Not sure how to do that if you don't have a copy of the old one though.  I've never had any luck "re-linking" a model to a drawing.

          • Re: Disappearing drawings
            Jeff Holliday

            Ok - as a starting point, Did you by chance move the location of the models since the last time the drawing was worked on (maybe with windows explorer)? If so, the drawing may not be able to find the model.

             

            If not, open the model and make sure the part has not been suppressed by some odd chance. If so, unsuppress them.

            • Re: Disappearing drawings
              Scott McFadden

              I sounds like the drawings are missing the link to the models.

              Are you getting dashed outlined boxes with "X's" through them?

              When you open the drawing before saying ok, click on the references button

              and see if your model shows up.

              • Re: Disappearing drawings
                Nick Grisco

                For some unknown reason, my drawing view will also disappear. All the annotations I previously made will still show up but the drawing view of my model will not be visible. The most reliable way I have found to fix this is to right click on the view in the feature tree and HIDE the view. Then right click on the view in the feature tree again and UNHIDE the view. Then it magically shows up again. Just one more idea that you can try that I know works for me.

                • Re: Disappearing drawings
                  John Stoltzfus

                  Good morning Martin,

                   

                  If your drawing shows boxes with an X across it the link is broken, otherwise try what Nick suggested.  What I do when this happens is to either, click the Tangent Edge Hide/UnHide or show or hide the hidden lines.

                   

                  John

                  • Re: Disappearing drawings
                    Don Eva

                    Not an actual solution to your problem, but an interesting trick was brought up at a recent NHSWUG meeting:

                     

                    If you have a drawing which has lost its reference to the model, you can open the drawing in edrawings - it will open the saved image and at least let you see what was there.

                    • Re: Disappearing drawings
                      Mark Kaiser

                      From the drawing, can you right click one of the drawing views (either in the feature tree or graphics area) and use the right mouse menu command to open the part file?  If the part files opens from the right mouse menu w/o going to an open dialog box, your drawing/part file link is still good.  If the part file opens, can you see the solid body in your part file?  I ask since I have mistakenly hidden bodies in part files, and they will no longer show in the drawing once they've been hidden (after a save and reopen, like one day to the next).

                      • Re: Disappearing drawings
                        Iain Kanics

                        I am encountering, what I believe, is the same problem Martin.  I am running SW2011 SP3.0

                         

                        Yesterday morning I opened a print I was working with the previous day, and only the format, and the few annotations I added the previous appear.

                         

                        The links to the part are fine, the part can be opened from the drawing, and equally odd, the views, dimensions, and annotations (none of which I can actually see and all of which still preview properly before opening the drawing) respond normally to mouse overs, ie their name pops up, their right hand menu works.

                         

                        Now any drawing I open has the issue of disappeared views.

                         

                        Further, the graphic window behaves oddly when a drawing is opened.  It doesn't refresh properly for example.  If I open a drawing, and then its part, and then close the part ... the part remains on screen even though mouse overs name the drawing views etc.

                         

                        Really a frustrating problem.

                         

                        PS - Hide/Unhide and changing tangent edge appearances do not appear to change anything.

                        • Re: Disappearing drawings
                          Iain Kanics

                          Martin,  my problem seems to have been solved after consulting with my SW service rep.

                           

                          Your video drivers may need to be updated.

                           

                          They recommended that I run SolidWorks Rx:

                           

                          "

                          Start --> All Programs --> SolidWorks 2011 --> SolidWorks Tools --> SolidWorks Rx.

                           

                          When the Rx utility comes up, click on the Diagnostics tab.  Once this populates, this should let you know if your video card driver is up to date.  In most cases, the behavior you've described is caused by running non-approved video card drivers.

                          "

                           

                          As I say, I updated my drivers (the machine is a Dell M90, 3 years old) and the problem did not occur the next time I launched SW 2011 3.0 my drawings weren't invisible anymore.

                           

                          Here's hoping the same solves your problem and that it doesn't come back ;-)