2 Replies Latest reply on Jul 21, 2011 3:03 PM by Tim Webb

    Corrupt archive server files

    Tim Webb

      3 weeks ago our corporate IT department transitioned one of my remote locations to a new domain. There is a replicated EPDM vault there and I had them leave that alone until I could get information from my VAR on how to move the data vault. So they "seemingly" left it alone.


      A week later I started getting calls from one of the engineers there that he was getting error messages saying "The disk structure is corrupted and unreadable" or "The latest version of the file is not available on your local archive server. All attempts to download the file from remote servers failed."


      I simultaneously started getting emails from IT that the backup agent was reporting folders that were corrupt and unreadable. These folders were inside the EPDM data folders.


      The EPDM data folder was on a mapped drive and after digging a bit, I realized during the domain transition the mapped folder got deleted. I had the local network admin remap it to where the data resided. I also worked with IT & tracked backwards from the corrupt folder names to find the actual files that were corrupt and they were all files that had been edited since the domain transition.


      Now apparently every file that gets checked out and checked back in is corrupt for any subsequent edits.


      I worked with one of the engineers there to have him save a backup copy of the files he had in his cache to a folder on his computer, delete the files from the vault, and re-add these files to force the file server to create new entries in the PDM data folder. That seems to work but only if every corrupt file and it's children/parents go through this operation as well.


      Has anyone ever experienced this sort of scenario?


      Any insight on what happened, or better yet, how to fix this problem would be appreciated.


        • Re: Corrupt archive server files
          Faur Arama


          Few weeks ago, we have problems with a replicated server and because in all pdm documentation there is no information about a procedure for removing or reinstalling an archive server we choose a wrong method. Every file that was on replicated server can not be accessed

          Our luck was that are few user on site and we can restore missing files from their local cache.

          Now I think that the best method is to have all files replicated on the main archive server, remove replicated server , uninstall replicated server.

          When the new server machine is ready is like creating the replicated archive server from start.

          Sorry but I don't a good advice for you