12 Replies Latest reply on Aug 22, 2011 3:23 PM by Kevin Lau

    2011 SP4 Hole Table BUG

    John Lhuillier

      If you use hole tables & just upgraded to 2011 SP4 then any new hole tables you create or old ones that get modified will no longer have the quantity of the holes for each callout. You can edit the hole callout string & add it in but the quanties will not show up. It is reported to have been fixed for SP5. If this affects you the SPR for it is 610875

        • Re: 2011 SP4 Hole Table BUG
          Steve Ostrovsky

          That's a really weird regression. I wonder what updates to Hole Tables were done from SP3 to SP4 that caused this? This was the only SPR fixed in SP4 that mentions Hole Tables directly:

           

           

          585433SolidWorks takes extremely long time to generate hole table for linearly patterned holes in this assembly.
          • Re: 2011 SP4 Hole Table BUG
            Randy Neumann

            John,

             

            Could you please show a screen shot or an example of this problem? I haven't seen any issues with my sp4 install, but others here have not upgraded yet and this could be a real problem if we upgrade all our seats.

             

            Randy

              • Re: 2011 SP4 Hole Table BUG
                John Lhuillier

                Here's screenshots of SP3 hole callout & SP4 hole callout. The SP4 callout has the quantity in the hole callout missing. They are OK if you just open the drawing in SP4 but if you need to modify any or create new ones in SP4 then you loose the quantity.

                  • Re: 2011 SP4 Hole Table BUG
                    Brian Lindahl

                    This might actually be a better error than in SW2010 (sp4.0).  When I "combine same size" holes, the <NUM_INST> variable reports the WRONG number of holes, rather than not showing any number.  See attached. In the table shown, there are not 16 "Axx" holes, there are 68, and there are not 28 "Cxx" holes, there are 36.  If I put a hole callout on hole A1, the qty for that callout (feature) quantity is 16.  The table is not "combining" quantities when sizes are combined.

                      • Re: 2011 SP4 Hole Table BUG
                        Anna Wood

                        I have to ask....

                         

                        Why would you list the number of holes in the SIZE column when you can see the number of holes by the TAG column?

                         

                        Just an observation......

                         

                        Seems odd that the NUM_INST is incorrect when SolidWorks can get the TAG count correct.  Sigh.....

                         

                        Randy works with me.  Now I know why we have not seen that issue with hole tables.  We do not add <NUM_INST> to our SIZE column in the hole table.  We let the TAG column tell us our counts.

                         

                        Cheers,

                         

                        Anna

                          • Re: 2011 SP4 Hole Table BUG
                            John Lhuillier

                            The one problem with the hole tables before they allowed you to reorder them was if you removed any holes, the numbering got all screwed up so having the actual count in the callout was helpful. Plus using the hole callout file for the hole tables, they're added automatically anyhow.

                            • Re: 2011 SP4 Hole Table BUG
                              Brian Lindahl

                              I've never done this on a production print, I was just testing the <NUM_INST> variable to see if 2010 was the same as 2011, when it displayed the more critical error.  We also allow the tag to effectively count the number of instances.  If a part is revised and holes go away, the table stays with missing instance numbers in the tags.  If the part is used as a seed to a new part, and holes go away, the drawing's table is deleted and re-inserted to generate new tag numbers with no gaps.  Again, the tags keep count.

                      • Re: 2011 SP4 Hole Table BUG
                        Karl Beardsley

                        We are having an issue with 2011 SP4 where Solidworks is crashing just trying to create a new hole table in a drawing. It crashes placing hole tables for both new parts and existing parts... Anyone know of any workarounds?

                          • Re: 2011 SP4 Hole Table BUG
                            Kevin Lau

                            I have the same problem. My workaround - create a new table without selecting any holes. After the hole table is placed, select the hole table in the feature tree and Edit Feature, then add in holes.

                             

                            There are some other issues like if your hole table template is with Table Header Bottom, new rows will be added under the header which kind of mess up your table. So you better change it to Table Header Top before you add in holes and after all holes are added, change it back to Table Header Bottom.

                             

                            Hope this helps.

                              • Re: 2011 SP4 Hole Table BUG
                                Karl Beardsley

                                Thanks Kevin, that works for me as well. Seems strange for a service pack to break the hole table... Hopefully they resolve it soon. Is there a SPR for this issue or should the original posters issue cover it?

                                  • Re: 2011 SP4 Hole Table BUG
                                    Kevin Lau

                                    Got from our VAR support:

                                     

                                     

                                    " SPR 610299: Instability when adding hole table to drawing in SolidWorks 2011 SP4

                                    According to SolidWorks, this problem should be resolved in SP5. They have also listed two other suggestions as a workaround:

                                    A) enable "use template settings" in Tools, Options, Document Properties, Tables or

                                    B) disable "combine same tags" in Tools, Options, Document Properties, Tables, Hole when placing the table and then make appropriate changes to the table after it is placed in drawing. "


                                    I tried both, only B works for me, just A or combined A and B didn't work.