50 Replies Latest reply on Apr 30, 2014 6:17 PM by James McKinney

    File>Open VERY SLOW

    Tony Szuta

      I have just upgraded my machine to SW 2011 sp4. I am running on an x64 platform. Previous to this, I have never had this issue but now when I click File>Open within the SolidWorks interface, I am faced with a minimum 15 second delay until the file dialog window opens. Does any one have any idea what may be causing this? I didn't upgrade my 2010 instalation, I started over clean. I don't see why it would matter, but my graphics card drive is using the latest and greatest SolidWorks certified driver.

       

      Any suggestions would be greatly appreciated but a solution would be best!

        • Re: File>Open VERY SLOW
          Tony Szuta

          I did yet another clean install. I am now running 2011 x64 sp0 without any issues.

          • Re: File>Open VERY SLOW
            Randy Shank

            Having the same SLOW OPEN issue with SP4 on a 64 platform, what was the fix here

              • Re: File>Open VERY SLOW
                Scott McFadden

                Hi Randy,

                Try running the Solidworks Rx tool and send that recording to your VAR

                for evaluation by Solidworks.

                 

                https://forum.solidworks.com/docs/DOC-1207

                • Re: File>Open VERY SLOW
                  Charles Culp

                  Randy,

                   

                  This is often due to a graphics card memory bandwidth bottleneck. What video card and driver are you running?

                   

                  Open up SolidWorks, but don't have it maximized. Resize the window to about 1/2 its normal size. Do you still have the problem? Do you see this problem when you first start SolidWorks, but there aren't any documents open? Do you only see it after opening up a part/assembly file first?

                  • Re: File>Open VERY SLOW
                    Randy Shank

                    @Scott, I will run the Rx tool and record the problem when I get an opportunity.

                     

                    @Charles, I didn't have this problem until I installed SP3.  I have a co-worker with the same machine as mine and he does not have this problem.  The graphics card we have installed is:

                     

                    PNY NVIDIA QUADRO FX3800 1GB GRAPHICS CARD

                     

                    I have the problem whether I have other files open or not.

                      • Re: File>Open VERY SLOW
                        Paul Marsman

                        Randy,

                          Charles other questions still need to be answered:

                        What driver are you running?

                        Does the problem go away with the SW window only at half normal size?

                        Does the problem start on the very first file in the morning after a fresh boot or does it get bad after a while?

                          • Re: File>Open VERY SLOW
                            Randy Shank

                            The driver we are running (both of us have the same driver with same date and revision) is NVIDIA Revision 8.17.11.9759.

                             

                            The problem does not go away with the SW window at half-size.

                             

                            The problem exists on the very first file of the day.  It does not seem to get worse after time.

                        • Re: File>Open VERY SLOW
                          John Sweeney

                          Tony and Randy,

                          Can you clarify this a bit for me?  Are you saying that the actual File-Open dialog doesn't show itself for 15 seconds or that the file being opened doesn't show itself for 15 seconds after making the selection in the File-Open dialog?

                           

                          Do you have any network drives mapped to local drives which are no longer valid?  Do you have any PDM type addins that are hooking into the File-Open process which might be causing a delay?

                           

                          Best Regards,

                          John

                            • Re: File>Open VERY SLOW
                              Jody Stiles

                              John,

                              A co-worker and I are having the exact same issue as Tony.  This is something new today.  We are running 2011 SP4.0 on Win 7 x64 Lenovo K320 systems.  Both machines are identical hardware and video driver wise (NVidie FX1800 w/ 8.17.11.9790).  We've been on SP4.0 from 2 days after it's release.  It seems irrelevant to when SolidWorks is started (first thing or after running other programs), when the Open command is issued (first command or after something else has been done), or how it is issued (File >> Open or CTRL + O).  It takes a good 15 seconds or so for the Open dialog to appear.  I've rebooted my machine as well as our license server (just in case) and the problem still persists.  I'd be happy to run an Rx and send it to you for analysis if that would help.

                               

                              Jody

                               

                              -edit 1: We run WPDM and have several mapped network drives (only one of which is mapped in SolidWorks file locations) but all seem to be working correctly.

                              -edit 2: After choosing my file by typing in the file name in the Open dialog file name field, arrowing down to the one I want, and then hitting enter, I noticed that the preview took a long time to show up compared to what I remember.  I want to say it took 10 seconds or so to see the preview for a file that has about 20 parts in it.  The file then opened in about 5 seconds from when I first saw the preview including rebuild time.

                              • Re: File>Open VERY SLOW
                                Ralph Wright

                                I have the same issue.  When I select the icon for Open File the windows takes about 15-20 seconds to appear.  We do not have PDMWorks.  I'm sending my VAR a Rx File this afternoon.

                                • Re: File>Open VERY SLOW
                                  Jody Stiles

                                  I wanted to add some numbers to my issue:

                                  • Start PC fresh
                                  • Start SolidWorks & Splash screen pops up - T=0:00
                                  • Splash screen disappears - T=1:50
                                  • DWG Document Manager missing error - T= 2:40 (new error)
                                  • SolidWorks opens with icons and menus- T=3:00
                                  • Click File Open - T=3:05
                                  • File Open window pops up - T=3:12
                                  • Type in model name and open it - T=3:15
                                  • Model opens with preview, rebuilds, and is ready to use - T=3:45
                                    • Model normally takes 2-5 second to show preview, 10-15 seconds to open and rebuild

                                   

                                  I treid to create an Rx but when I clicked on Package Files, nothing happened even though I got the pop-up with hyperlinks to where the zip file and folder is.  Clicking the links did nothing.

                                    • Re: File>Open VERY SLOW
                                      John Sweeney

                                      When the File-Open dialog appears, is it pointing at a folder with hundreds or thousands of SolidWorks files?  Try browsing to a folder with only a few SolidWorks files and open one of them.  Now close the file and select File-Open again.... is it faster.

                                      Thanks,

                                      John

                                        • Re: File>Open VERY SLOW
                                          Jody Stiles

                                          Currently it's pointing to my working folder which contains ~1,300 files.  This workspace typically has close to this amount of files in it and the Open window typically comes up instantly after hitting open.  I did notice over the last month or so a hiccup in the way files were displaying in the Open window.  I noticed that the files would come in with default icons (list or detail view) but would then change to the preview image icons in a wave running down the window.  If I were typing in a file name in the File name: field, the list of matching file names below the field would disappear.  So if I had typed in my file name and was arrowing down the list, the list would go away and I would have to type something more in the File name: field to get it to populate again.  This isn't happening now, I can only assume because it is taking so long for the Open window to come up.

                                           

                                          I just opened to a location containing 6 folders, 2 assemblies, and 4 parts and it took ~10 seconds on a stop watch.  I tried opening to the same location several times all with the same delay.  It's basically the same delay I see in my working folder.  If I browse from the small folder to my working folder; the working folder populates the entire Open window as it typically did.

                                           

                                          I just noticed that all of my file icons in my ~1,300 file folder are showing as a white piece of paper in all view modes (list, details, thumbnails)

                                          • Re: File>Open VERY SLOW
                                            Jody Stiles

                                            John,

                                             

                                            I was just poking through my local license server application and noticed that it was pointing to my Beta server.  I changed it to my normal server and most of my issues went away with the exception of the DWG Doc Mgr error.  I checked my co-workers PC and his was still pointing to the current license server

                                             

                                            I thought I read that the Beta install could be done parallel to a current install without any issues as long as the SNL was running on a separate server (which mine is).  I could not get the Beta to run on my box so last week I used a restore point to "undo" the install and probelms I was having with 2011 sp4 but apparently it didn't work fully.  Can a beta install be done on the same machine as a current version?

                                          • Re: File>Open VERY SLOW
                                            Keith Yeager

                                            I have been experiencing this problem as well.  We use a network license and solved the issue by reordering the licences in the License Manager.  SolidWorks Premium was set below the Flow and Simulation licenses initially, but once I moved it up to the top of the list, the software opened quickly, and the Open File command worked quickly. 

                                             

                                            Potentially helpful info - if you think it may be a network license problem, you can "borrow" the licenses for the machine through the license manager, then unplug the machine from the network and open the software.  It worked fine when I did this but slowed when connected again... until I changed the license order.  Hope this helps.

                                      • Re: File>Open VERY SLOW
                                        Alin Vargatu

                                        Is there any way to remove the "Answered" tag to a thread? This one for example has not been "answered".

                                        • Re: File>Open VERY SLOW
                                          Grant Sonneman

                                          Same problem here. I was using SW2011 SP4 64-bit without any problems. This week I noticed the slow open problem you describe. It seemed to work one day and not the next. Has anyone had any luck fixing this?

                                            • Re: File>Open VERY SLOW
                                              Michael Young

                                              Might have found a solution accidently:

                                              Go to your computer where the license manager is installed.

                                              Open the license manager, server admin tab, license info, modify.

                                              Activate/reactivate, then next

                                              We checked the box “a firewall is in use on server”, then verified the port #’s.

                                               

                                               

                                              After this change was made the file/open dia box comes up in a second. We just figured this out about a ½ hr ago, so no long term testing has been done.

                                               

                                              I’m running Win7 with SW 2011, x64, SP 4.0 and the server is also Win7 and should have all updates installed. I only came across this open dialog box delay after upgrading my machine from XP to 7 (the server was the same for both machines).

                                               

                                              Hope this helps someone.

                                            • Re: File>Open VERY SLOW
                                              Whit Smith

                                              Looks like Im digging up an old thread but me as well as two others are experiencing this same exact problem.  I am running SW 2011 SP 2, Dell Precision M6300, Windows 7 64. My last working configuration is as follows: floating license, working out of PDM vault, running 4gb ram.  About a month ago my system was "updated" and or network was changed.  Now I am running 8gb of ram, working out of PDM vault, floating license on a VPN.  Vault is on the VPN as well.  I thought this was a network issue so I checked out a license, which took forever because my license manager has started to freeze up and crash since the update above has taken place.  Then pulled my files to my hard drive, completely eliminating the need to be on a VPN.  Nothing has changed.  It is still slow opening like in the earlier posts regardless if Im on a VPN or not.  On top of the slow opening it crashes constantly.  Is there anything that I can check or settings I can change somewhere to help this problem?  Im almost at a standstill becausof this problem.

                                                • Re: File>Open VERY SLOW
                                                  Randy Shank

                                                  Whit,

                                                   

                                                  I tried all the suggestions that everyone listed above, but nothing worked.  This problem went away for me when I installed SW 2012.  I updated all the service packs under 2012, and now I'm running SW 2013.  I have not had any problems since my upgrade to 2012 a little over a year ago. 

                                                   

                                                  Maybe you'll have success, but none of the suggestions on the forum worked for me.  I wasn't notified of any fixes from SW either, other than the newer versions.

                                                    • Re: File>Open VERY SLOW
                                                      Whit Smith

                                                      Randy,

                                                       

                                                           Thanks for the info.  We are suppose to be going to 2013 after the first of the year but until that is installed I guess I am stuck with this problem.  I honestly dont think its a service pack error though because I was running 2.0 before my ram upgrade and am still on the same service pack.  Thats the only thing that has really changed, and it only affected SW.

                                                        • Re: File>Open VERY SLOW
                                                          Whit Smith

                                                          Just an FYI, my issue was resolved.  I got a virus last week and had to have my computer completely rebuilt.  Hard drive was wiped, Windows 7 reinstalled, and SW 2011 SP0.0 installed.  After that my system has been performing great.  Fast file opening and loading.  This week I had SW 2013 SP0.0 installed and the performce was the same, couldnt ask for anything else.  One last thing, when my system was rebuilt I had the latest invidia driver installed because the SW website didnt have a recommended one from their list.  It has been working great, so this may have been part of my issue  before.

                                                    • Re: File>Open VERY SLOW
                                                      Jack Hidley

                                                      I have the same problem SW 2012 SP5 on XP Pro with 4GB of RAM. The File menu opens very slowly. This takes about 10-20 seconds. Once I get it open, files load and close with normal speed. The machine is using the SW Network Licnese Manager over a VPN. All of the files are stored on the local machine. I looked into what M Young posted above, but none of the items mentioned in his post seem to apply to the current LM software.

                                                       

                                                      The video card is an Nvidia Quadro FX580 with driver version 6.14.12.7071. This is the latest driver version approved by SW. The latest driver version causes the computer to lock when the file menu is accessed for 10-20 seconds. In the Nvidia control panel, there is no 3D profile for SW. There is one for Dassault system CATIA. This selection causes problems. 

                                                        • Re: File>Open VERY SLOW
                                                          Jack Hidley

                                                          Does anyone from SW read these forums?

                                                          • Re: File>Open VERY SLOW
                                                            Anna Wood

                                                            Jack,

                                                             

                                                            I suspect your computer is hunting for the license server on SolidWorks start up.  I have seen that happen on my systems.

                                                             

                                                            Has the license server path or name been changed recently.  May have something to do with trying to access the license server over the VPN as well.

                                                             

                                                            Try and borrow a license for the day.  Then try opening launching SolidWorks.

                                                             

                                                            Cheers,

                                                             

                                                            Anna

                                                              • Re: File>Open VERY SLOW
                                                                Jack Hidley

                                                                Anna,

                                                                 

                                                                Thanks for the idea.

                                                                 

                                                                I tried borrowing a license. It made no difference.

                                                                 

                                                                SW opens plenty fast. It is just when you click on the File pull down menu, that it takes 10-20 seconds to respond. It doesn't matter when you do this, the behavior is the same.

                                                                 

                                                                It makes the program unusable. You click on the File menu once and wait. If you click on it in the next 10-20 seconds (anytime before it opens), it buffers the second mouse click, so when it opens, it nearly instantly closes again. You have to click on it once, wait and don't move the mouse at all, until it opens.

                                                              • Re: File>Open VERY SLOW
                                                                John Sweeney

                                                                Hi Jack,

                                                                 

                                                                It might be your list of "Recent Files" has a reference that is slowing you down.  Try hitting the "R" key which brings up all the recent files in a preview window.  Is that slow too?  If so, look thru the list of files and see if one of the files is on a server with slow LAN access or if one of those servers is no longer available on your network.

                                                                 

                                                                Best Regards,

                                                                John

                                                                  • Re: File>Open VERY SLOW
                                                                    Jack Hidley

                                                                    John,

                                                                     

                                                                    I only access files on the local computer. There is no way that there could be a speed access problem to one of them.

                                                                     

                                                                    The only way to get to the point where the R key can be pressed, is to have the File menu open. The File menu opening is the slow part. Once it opens, any of the commands within it respond quickly. 

                                                                      • Re: File>Open VERY SLOW
                                                                        John Sweeney

                                                                        Hi Jack,

                                                                        Actually, unless you've changed your UI customization, you can simply hit the R key to show recent docs in a special preview window.  This is a global shortcut that we add by default and it is usable everywhere except when you are in a text edit field.

                                                                         

                                                                        Another test to narrow this down is to clear your "Recent Files" list.  If you're comfortable editing the registry with the "RegEdit" tool, simply close SolidWorks and then rename the following key:

                                                                            

                                                                             HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2013\Recent File List

                                                                         

                                                                        Restart SolidWorks and see if the menu is faster.

                                                                         

                                                                        Best regards,

                                                                        John

                                                                      • Re: File>Open VERY SLOW
                                                                        Rachel Bolinger

                                                                        Hello,

                                                                        I'm getting the same issue on my 2013 SP2. I never had a problem with 2012 and right when I began using 2013, the File--> Open takes a much longer time to open. I read through these posts and haven't seen anywhere on them that the problem was fixed. Have we figured out what it could be? It's rather annoying I have to say.

                                                                         

                                                                        Thanks,
                                                                        Rachel

                                                                          • Re: File>Open VERY SLOW
                                                                            John Sweeney

                                                                            Hi Guys,

                                                                            Take a look at this KB article S-055988 . It sounds like a similar situation related to an SNL issue.  The only difference is the KB article claims the slowness is with the File-Open dialog, not the File menu. 

                                                                            -John

                                                                              • Re: File>Open VERY SLOW
                                                                                Jack Hidley

                                                                                John,

                                                                                 

                                                                                I am not using PDM. There are no add ins loaded. I checked the S-055988 article. There is only one license server in the server list.

                                                                                 

                                                                                Regarding slow menus. In SW, the only menu that responds slowly is the File menu. All others respond quickly. However when SW is open, it causes other progams File menus to work slowly. However this is inconsistent. One really strange thing is with SW open, if I click on the Start button then Programs, it can take 30 seconds for that to respond. All of the other selections under the Start button, Documents, Settings, Search, etc respond normally. This only occurs when SW is open.

                                                                              • Re: File>Open VERY SLOW
                                                                                Jake Boening

                                                                                If you also moved to a new license server when you upgraded to 2013, there may still be at least one reference to the old server in the client's registry. In my case it was registry key HKEY_USERS\S-1-5-21-661076659-876009293-3078871202-1000\Software\FLEXlm License Manager\SW_D_LICENSE_FILE. After updating this (I did not try removing it but that might solve the problem too), SolidWorks and the File>Open dialog opened much more quickly!