9 Replies Latest reply on Jun 9, 2011 6:21 PM by Ray Luck

    Cannot create Solidworks Part or Assembly

    Ray Luck

      Hi,

       

      We've recently installed EPDM and I'm just getting familiar with the structure and basics.

       

      When in explorer I can right click and select 'New' and 'Folder' and name the new folder. But if I select New Part or Assembly I get an error. I'm sure I've overlooked a permission option somewhere but I'm unsure which one.

       

      Thanks.

       

      Ray.

       

      EPDM.png

        • Re: Cannot create Solidworks Part or Assembly
          Andries Koorzen

          Hi Ray.

           

          The best way to troubleshoot this would be to open the administration tool (if you have access to it) and go to the workflow.

          Select the workflow state that are are trying to copy "from" e.g. if the file is in the approved state, select the approved state in the workflow section, and make sure that you have the rights you need in this state to copy files

           

          **

          • Re: Cannot create Solidworks Part or Assembly
            Faur Arama

            Hi Ray

            The part that you want to use as template is checkin?

            On what credentials you run this template? The user on witch credentials you run this template has "Read.." rights on part workflow and folder?

            • Re: Cannot create Solidworks Part or Assembly
              Wayne Tiffany

              Interesting.  When I RMB I don't get the option of creating a new SW part or assy.  I can create a new Office doc, but no SW files.  But I'm also a bit confused as to why you would want to create a SW like that.  Are you trying to create a new file as part of a workflow?  What's your thoughts here?

               

              WT

              • Re: Cannot create Solidworks Part or Assembly
                Wayne Matus

                I know you do not want to hear this, but EPDM is a software package that most companies purchase an implementation service from their VAR to get them up and running. As a bear minimum you should at least attend an Administering EPDM training class.

                 

                After looking closer at your thread, it looks like someone did setup your vault for you. It sounds like someone setup templates for creating Parts and Assemblies. Your first line of support would be the person that did your implementation.

                • Re: Cannot create Solidworks Part or Assembly
                  Pedro Branco

                  Hi,

                   

                  You dont have permition to create files on the template destination or read the  template source file. The Administrator can quickly fix it by changing permitions for you or run the template with a user with sufficient file permitions.

                   

                  TemplateSnapshoots.png

                   

                  Regards,

                   

                  Pedro Branco

                    • Re: Cannot create Solidworks Part or Assembly
                      Ray Luck

                      Hi All,

                       

                      Thank you for your replies.

                       

                      I will try and answer one by one.

                       

                      Scott, yes I am trying to create the part in EPDM.

                       

                      Faur, the template is not checked in. We have an assembly template and a part template that are configured in EPDM.

                       

                      Wayne T, Well I was creating the file first, however the result was the same as going to Solidworks File-New-part/assembly. I should point out that under file locations in Solidworks, our templates are the templates in EPDM. Which are actual Part/Assembly Files not the usual .prtdot, drwdot, asmdot.

                       

                      Wayne M, I am aware of this and yes we purchased EPDM with a quick start implementation package. I have a contacted our VAR and they are working with us but I still like to put things into the forum just to hear peoples opinion.

                       

                      Pedro, this solved the problem. Thank you!