27 Replies Latest reply on May 15, 2017 10:09 AM by Dan Pihlaja

    Stop auto positioning my dimensions!

    Ryan Tosto

      I have a problem with SolidWorks auto positioning my drawing dimensions.  I need to fix the dimension text where I put it, so that when I switch to a different part configuration it doesn't move.  I posted two screens shots of what's happening. How do I permenantly fix the dimension's position on a sheet?  It's driving me nuts.

       

      The reason I need them fixed and can't manually change the text position is that I run a macro that automatically generates drawings and PDFs for all of my configurations.  I need to create over 70 drawings of different configs and can't be fiddling with dimensions for each config.

      Config 1 - Good SolidWorks:Configuration 1 - Good.png

       

      Config 2 - Bad SolidWorks:Configuration 2 - Bad.png

        • Re: Stop auto positioning my dimensions!
          Troy Peterson

          Options -> System Options -> Drawings -> uncheck "Reduce Spacing"

          • Re: Stop auto positioning my dimensions!
            Scott McFadden

            Ryan,

            Welcome to the forum.

             

            Is this what you are talking about?

             

            https://forum.solidworks.com/message/191750#191750

            • Re: Stop auto positioning my dimensions!
              Jeff Holliday

              It looks like your dimens are right-justified, would it help if they were left-justified instead?

              • Re: Stop auto positioning my dimensions!
                Dan Miel

                When do the dimensions change? Is it when you run your macro? We were having problems with dimensions changing on one of our macros and we traced it to a drawing template that had not be opened and resaved to 2010. After we updated the template the problem disappeared.

                Dan Miel

                • Re: Stop auto positioning my dimensions!
                  Stephen Reed

                  I find the auto spacing feature a 2 edged sword. It's both a great time saver and as in your case, a huge aggravation.  This is more of a work around because I do like and use the feature; but if you let it place the dimensions automatically, then exit out of dimensioning, you can then drag the dimensions to where you want and they will stay put. At least that has been my experience and how I work around it when I don't like where SW placed the dim.

                   

                  Steve

                    • Re: Stop auto positioning my dimensions!
                      Denny Metcalf

                      They will stay put until the next time you import dimensions, then all of your work locating them on the drawing will have gone to waste.

                       

                      The irony here is that some companies will rev up a drawing when dimensions are moved but nothing has changed. Some companies maintain revision levels for both the assembly drawings and the parts drawings. Some companies don't make any distinction between the two.

                       

                      With the SolidWorks workflow, if your dimension gets bumped around and you're a company that has to rev up a drawing for every little thing... what do you do? I sincerely doubt you will be able to put all of your dimensions back exactly as they once were without some kind of snap points...

                    • Re: Stop auto positioning my dimensions!
                      Denny Metcalf

                      This is the only way I was able to find that will consistantly work but it is a pain in the... mind you.

                       

                      1. Select all of your dimensions and hide them.

                      2. Change your configuration or import additional model items.

                      3. Unhide your dimensions.

                       

                      Told you, it's a pain...

                       

                      Some thoughts...

                       

                      Almost always, I use the dimensions from the model and import them into the drawing. Because of this I make sure the default dimensions are not marked for drawing, and then I go back and hand select the dimensions that I want to import.

                       

                      Often when I model, I don't actually use dimensions but instead use references or relations. In this case I add reference dimensions within the model that I will then import into the drawing. Becareful how you select your geometry so that they remain robust.

                       

                      When you have imported dimensions in your drawing that you don't want, don't delete them. Just hide them. That way when you want them again you can just unhide them so that you don't have to have all your dimensions fly all over the place again when you bring them in. Also, every time you delete them from your drawing, if you import model items again and it's still marked for drawing, it will get imported yet again. So yeah, don't mark it for drawing or hide it, don't delete it.

                       

                      You have some limited control by setting your drawing's document properties. Under the dimensions section you can set your offset distances, arrow sizes, extension line gaps, etc. They will still move, but at least if these values are small enough they won't be clear on the other side of the drawing (so easier to find when they do explode, and you know they will...)

                       

                      The option to reduce spacing in the system options does nothing in this regard. It's, uhm, broken? Featuring a regression? On holiday?

                       

                      Also, part of why your dimensions are not lining up is because of where they are located with respect to your drawing view and part geometry. You and I both know that it's a perfectly fine location to place dimensions but SolidWorks doesn't know that. This part isn't even bad too. Imagine a big sheet metal L shaped part (big big flange) where you'd want to utilize the space but SolidWorks thinks that your dimensions are on the drawing view (and yes, they are, ya ya ya). This is where the offset distances no longer work since they're automatic. Offseting dimensions is one of the few things about ProE drawings that I miss.

                       

                      Or you can just kind of place them nicely in the model and then import them from their sketch placement and move them again in the drawing (since inevitably you know you're going to move them one way or another).

                      • Re: Stop auto positioning my dimensions!
                        Paul Marsman

                        I think this might be it:

                        Fixed in 2011 SP4

                        SPR 581528: dimensions autospace after modifying dimension properties, even when system option is disabled

                        • Re: Stop auto positioning my dimensions!
                          T. Walker

                          To turn off the auto-centering of dimensions text (with Version 2016), right-click the text, select "Display Options" and deselect "Center Dimension".

                          From there you'll be able to slide the text toward either dimension arrow.

                          I hope this helped.

                          • Re: Stop auto positioning my dimensions!
                            Dan Pihlaja

                            Here's a little test:

                            Test parameters:

                            Create a feature .5" wide and create configurations that increase the width of that feature by .25" intervals up to 2".

                            Create a drawing and add a dimension, offset the dimension approximately .5" from edge.

                            Switch configurations and see approximately where Solidworks places the dimension. No manual movement of dimension after 1st placement.

                             

                             

                            1) Dimension set to .5".  Dimension placed approximately .5" from edge

                             

                            2) Dimension set to .75".  Dimension placed approximately .85" from edge

                             

                            3) Dimension set to 1.0".  Dimension placed approximately 1.2" from edge

                             

                            4) Dimension set to 1.25".  Dimension placed approximately 1.55" from edge

                             

                            5) Dimension set to 1.5".  Dimension placed approximately 1.9" from edge

                             

                            6) Dimension set to 1.75".  Dimension placed approximately 2.25" from edge

                             

                            7) Dimension set to 2.0".  Dimension placed approximately 2.6" from edge

                             

                            I have also attached a video to show you what is happening.

                             

                            This is an automatic feature of Solidworks.  I don't know WHY it does this.  It also does this in Sketches at the part and assembly levels.

                            I don't think that we can change this.  Maybe an enhancement request?